Maintenance work on GitLab server: 2023-11-09 / 2023-11-10

IMPORTANT: server migration news for 9/10 Nov 2023. The final step of our server upgrade is now complete and should reach you very soon if you aren’t already on it (the server change takes time to get to be reflected on all Domain Name Servers so it’s unpredictable when it will reach you). You may notice issues such as results files not appearing immediately. See below for details.


Dear all,

I will carry out some maintenance work on our GitLab server tomorrow, Thursday 2023-11-09, from 8am GMT.

This will not prevent participants from running your experiments.

Some of you may however notice that new participant results are not appearing in the experiment’s GitLab repository right away: they will have appeared by Friday at the latest. If you need them ahead of time, you can download them from your experiment’s page.

Similarly, some of you may notice that a newly created experiment is not appearing on their dashboard on it will also have appeared by Friday, at which point it will be possible to pilot it.

Finally, to further minimize impact, new users will be prevented from registering with GitLab until the maintenance period is over, by Friday.

Thank you very much for your understanding.
Best wishes,



Dear Alain,

I am still unable to upload new experiments to the server.
It produces an error code.

How much longer will maintenance take?



1 Like

Hello everyone,
I am in the same situation,
I start data collection on Monday and need to sync the latest version of my experiments.
Thanks in advance!

Hi everyone,
I am in the same situation too. Trying to upload a new experiment, I get an error
“Could not find project with id 345504 on Pavlovia”, although the project was never created before.


Hey everyone,
It works again !

1 Like

Good afternoon,

It is now possible to create experiments again, indeed, and change their status on their page on
I am still working on reconciling the data between and gitlab, which will take a bit longer.
But you should be good to go.



As soon as you have access to the new server (most people should have this already, but it will happen at different times for each person as the world’s Domain Name Servers gradually reflect the new address) you should find everything is now working, and you should have a lovely new interface for

If you aren’t sure whether you’re on the “new” or “old” server then open a project on and take a look at the files. The new server has cute little file icons to show the different filetypes, which weren’t there in the original:

(That isn’t the only difference - there are many improvements on the new server - but that’s one that is easily visible)

Well done to @apitiot who performed some pretty heroic miracles to migrate a huge and complex server with relatively minimal impacts. Although sync from PsychoPy stopped for a period, Pavlovia didn’t stop collecting participant data at any point and the web interfaces to both Pavlovia and Gitlab were available throughout. Yay for Alain!! :smile:


Dear Alain
thanks for upgrading Pavlovia. Should it be working normally now? I still can’t create a new study.

When I try to create a new study from EasyEyes, it creates the Pavlovia repo and uploads to it, but dies with a CORS error in the last step (screenshot below). I can run my old studies, but my new study fails with a 404 error.

What do you think? Is this a temporary glitch? Or is it a change in the Pavlovia interface that we need to adapt to?

Again, thanks for the upgrade.

Hello @denispelli ,

I have just deployed a first attempt at fixing the Sign-Out problem. You will need to empty your browser cache and reload for it to become active.
Clicking on Sign-Out will now take you to your GitLab dashboard page, from where you can sign-out properly (by clicking on the top-right profile icon), upon which you will be taken back to /explore

It is actually a GitLab issue that they have not fixed for years (Sign out link broken on 404 page (#202291) · Issues · / GitLab · GitLab). Obviously, my own fix is not ideal, and I will keep at it throughout the week-end.

I will also get back to you shortly regarding the CORS issue, hopefully by tomorrow.
With my apologies for the trouble.


1 Like

Dear Alain
Thanks. In the meantime I convinced myself that the Sign out confusion was not actually a bug, just a terrible user interface. I think that the first time that I clicked “Sign out” it actually did sign me out, but didn’t bother to tell me. The second time I clicked Sign out, I wasn’t signed in, so I no longer had permission to use the sign-out page, which produced the 404 error.

I’ll try your work around. THx.
Sorry I removed that part of my query before seeing that you’d replied.

If I go to I can find the repo EasyEyes created, and manually set it to RUNNING mode. When run, it starts, but hangs up with a 404 error while the screen says “Initializing the experiment …”.

:white_check_mark: GOOD NEWS. As you know, since the Pavlovia upgrade today, EasyEyes fails while trying to upload an experiment. Happily, Peiling Jiang, PhD student at UC San Diego, discovered that this only affects EasyEyes experiments saved as XLSX file; CSV files are ok. So we are working around the problem simply by using CSV files. Peiling suspects that the problem may be in the binary upload of the XLSX file. In fact the uploaded XLSX file has always been corrupted, so our first step toward solving this problem will be to debug that upload. A wild guess is that we’re using the wrong MIME type. It’s good that the Pavlovia upgrade removed its former tolerance of broken uploads. At this point it appears that Pavlovia is fine, and that EasyEyes has a fixable problem with XLSX-file upload. Thanks.

1 Like

When will the registration page be back on the website?


when trying to log in Pavlovia via Psychopy Builder, a window launches (after clicking the login button) which just continuously loads (without being signed in yet). It’s only starting to happen this week. Would this be due to the server change? Me and a colleague have tried this separately on our own laptops with the same result. We’re using Version 2022.2.5. thanks

Hi There, I encountered this same issue this morning but then retried just now and all appears to be well - could you please confirm you can log in from the app now?


Hi Everyone,

We are aware of a Timeout error currently effecting some users of We are aware of the issue and are currently investigating. We will keep you informed once we have it resolved.

Apologies for any inconvenience this might be causing,

The above issue should now be resolved.

I did some additional work on the new servers at the week-end. As a precaution, I disabled registration for new users.
It become possible again this morning.