Launching Issue

OS : macOS 11.4
PsychoPy version (e.g. 1.84.x): 2023.2.3. for macOS
**Standard Standalone? (y/n) y but also tried pip install and conda
**What are you trying to achieve?:
I would like to run PsychoPy. I had it before. I uninstalled it – by deleting it from the applications as I have previously used the standalone installation. I reinstalled it and now I get an error message when I try to launch it refers me to the py2app website for debugging.

**What did you try to make it work?:
I tried uninstalling it again and then reinstalling it. I tried to install it with pip. When I tried to open it, it still gave me the same error message. I have tried to edit the preferences files with the hope that the issue would be there but that still didn’t help.

**What specifically went wrong when you tried that?: I tried to run various things in the terminal based on previous post on this issue. I can’t replicate things now to provide more detailed information about the issues. I am open to run anything in terminal or try whatever to get this work. I’m sorry I’m not being more precise about this.

Hi There,

Unfortunately this is an error we’ve seen crop up a few times and it is to do with using older versions of mac OS. The only work arounds I 've seen at the moment are to run an older version of PsychoPy or perhaps you could run an update on the OS?

Sorry to not have a better solution at the moment!