psychopy.org | Reference | Downloads | Github

How to restrict the sentences into psychopy window?

If this template helps then use it. If not then just delete and start from scratch.
OS Mac
Psychopy3
What are you trying to achieve?:
locate the sentences all in the screen.
What did you try to make it work?:
I want to make a middle bar to split the window left-right half-half. then right side to display questions into the right side window no matter how long is the sentence.
What specifically went wrong when you tried that?:
I located the Position[x,y] as (0.4, 0.3), and the question sentences appeared in the middle of right side half of the window, but the sentences exceeded the Psychopy window from right side, i.e. some words of sentences missing out. on the left side, I want the sentences not to exceed the middle bar but the sentences got across it to the left half of the window.

Have you tried changing the wrap width? Are you using height units? Norm units work better in your situation.

thanks very much, I set the wrap width to be 0.6 and it looks quite good when the sentences get wrapped automatically according to window size :slight_smile:

I have another question: have you guys tried to present Chinese characters in the window? the chinsese characters in the sentences only show up half of them, i.e., each character doesn’t get full show up presenation. is it related with font ? and how to address it?

I have presented Chinese characters though one at a time. Are you trying to present wrapped Chinese text? If so, then do try a smaller or different font. Please could you show a screen shot of your text component and of the resulting text?

the Chinese text in left half side of the screen are supposed to be: 但 受害人 的 哥哥 表示 想不出 有 谁 会 想要 加害于 他 , 并称 “ 一切 终于 好 起来 了 。 ” but it showed like attached, each chinese character is hiding some part.

If it’s all on one line as shown then I’ve had that issue in English. The solution is to add newline characters \n at the start and end of the text to give more vertical space.

I managed to wrap the left side chinese sentence by setting the wrap width to be 0.6 as well. however, the issue is the character presentation. each Chinese characters does not present fully, as in the screenshot. so, do you know how to set or adjust the font for Chinese? :slight_smile:

I solved the Chinese character issue just change font into Songti SC ref: Problem with text display - Chinese characters cropped - #3 by Liory
Thanks wakecarter

Cool. What font were you using? I think I just used Arial.