Fully Uninstalling PsychoPy on a Mac

I’m having some consistent errors in PsychoPy that I have tried everything to resolve, including uninstalling PsychoPy and reinstalling it on my Mac. Regardless, I keep getting the same errors over and over for every task I try to run. I think it’s related to a Pavlovia related connection, but I can’t figure it out. I’ve been installing PsychoPy from the .dmg file (not pip through terminal). How do I properly uninstall PsychoPy and all of it’s buried dependencies and programs on my Mac? I’m running OSx 12.4. Thanks!


As far as I know, if you have not moved files after installation, it is OK normally.If you have moved, please search in this computer, delete the configuration file related to psychopy

PsychoPy and all of its dependencies are entirely contained within its application package. So simply go to your applications folder, select the PsychoPy icon, and throw it in the trash.

However PsychoPy will also save certain settings and configurations – it is probably a good idea to first try clearing those before you delete the application, as corrupted settings might be the cause of your problems. You can safely delete them, as if they are missing, they will be re-created afresh the next time PsychoPy is launched (be selective though - for example you probably don’t want to throw out your monitor definitions).

The relevant files (appData.cfg and userPrefs.cfg) are described here:


Those settings will probably be stored in an invisible folder called .psychopy3 in the top level of your user folder. You can view this folder in the Finder by navigating to your user folder and then pushing command + shift + . simultaneously, which will reveal all invisible files, and enable you to trash them like regular files.

You might have also installed PsychoPy’s demo experiments somewhere on your disk - I think you get to choose where those go, so I can’t help with how to delete them, but they can’t do anything unless you choose to run them.

This worked well Michael. Thank you! It was the invisible folder as you suspected. Once I deleted that and reinstalled psychopy everything worked again.