psychopy.org | Reference | Downloads | Github

Psychopy does not open, again

I just can’t open Psychopy. I tried uninstalling everything, included other programs that use python and may interfere. Cleaned Appdata. Now I’m just a bit lost. The only thing I tried is opening python, and when I try to import psychopy I get this:

image

Any help, in any way, will be well received

Greetings!

Just for an update: I tried uninstalling everything, just installing python from python.org, and use pip install. Failed again. I asume I’m failing to erase everything I must erase.

Oh this mess. Yeah I ran into this too while trying to get PsychoPy on my system’s python3 environment, and I did manage to fix it, but it’s annoying. If you’re on a mac, I had to first solve the problem with installing pytables, which required using homebrew to fix c-blosc using:

brew install c-blosc
brew link --overwrite c-blosc

Then manually running PsychoPy’s setup.py.

The fundamental issue is with pytables, so I basically googled all the issues with pytables first and that eventually led me to the right solution.

However, the standalone app version just works for me regardless, so unless you specifically need it on your system python you can just use that.