Forbidden error on Pavlovia

URL of experiment:

Description of the problem:
I have made a task using psychopy which is running fine. I have uploaded it onto pavlovia but i am getting the forbidden 403 error. I tried to export to html, i have tried syncing it, and I have used different laptops to upload it but i am getting the same error.
Can anyone help me please?

Do you get a traceback when you try to sync?

When I sync a window pops up that says create a new project…I’m not sure about the traceback

How do I see the traceback?

If it asks you to create a new project and you say no then it isn’t an error, so no traceback.

Is your local file on a cloud drive? That could be causing the issue.

No it’s just saved onto my desktop on my MacBook. When it tells me to create a project I press yeah. Should I be doing something different?

By desktop – in it’s own dedicated folder or is the experiment file itself on your desktop?

Yes, on my desktop i have a folder: and within that folder is all the condition files and the psychopy file. Screen Shot 2021-04-25 at 21.51.07
I have uploaded a screenshot to illustrate what i mean

Do you have more that one psyexp file in there?

The & symbols might cause an issue.

i only have one psyexp file in there. I changed the folder name to ‘AgeingTask’ so now there is no & symbols but i am still unable to get a running task
here is a screenshot of what is inside the folder

the one called ‘finaltask.psyexp’ is my task and the rest are conditions and stimuli. Im not too sure what all the ‘lastrun’ files are and whether that might be causing the problem?

Given all of the files from previous experiments in there I’d suspect that you might well have a hidden .git folder which can remember previous experiments.

You should probably either delete it of copy just the files you recognise to a clean folder.

Ill try that now! do you think i should copy over the lastrun files too and the html file? Or just the condition files and the psyexp. file?

just the condition files and the psyexp. file

Hi! i have just tried that and i am getting this error which i havent seen before

here is the URL:

Are you sure you didn’t copy across the .git folder?

Try the following.

Create a new local folder.

Connect that local folder to your online repository by following these steps

Then copy any missing resources and the psyexp file if needed into that new folder.

I have just tried that. I am getting this error now…

also when i view the code for the study it says " The repository for this project is empty"


I have now managed to get it running but there is this error…do you know what this may mean?

Check my crib sheet for how to view the browser console to discover what is undefined.

I have just read the crib sheet and im guessing this is the solution: If your experiment works locally then this can probably be solved by adding appropriate definitions in code_JS.

However i am unsure of how to go about this. do you have any tips?