404 Not Found when running an experiment today, that worked last night


Description of the problem:
My video classification experiment working late last night, today I find that I’m unable to pilot or run the experiment. When I press the “pilot” or “run” button (when the project status is set to the respective modes) I get a 404 Not Found (nginx) error. In the console it says “Failed to load resource: the server responded with a status of 404 ()”. This occurs in both Firefox and Google Chrome web browsers.

Was there any Pavlovia server maintenance performed recently?

It now also hangs on “updating the experiment…” if I try to change the status of the experiment. Which makes me wonder whether these errors are arising as the experiment status has not been changed properly. Although if I reload my Dashboard, I see it lists the experiment status as changed.

Hi @MichaelJoannou, normally a lib folder is created with each project where PsychoJS related imports are automatically placed and which seems to have gone missing here. Would setting up a new repository be an option for you? I tried forking and GitLab seems to be struggling with it, quite possibly for the same reason, x

Hi Sotiri, thanks for your reply, I’ll give it a try and if it doesn’t work I’ll post the new project in this thread. I think the fork would take some time as there is around 5.5GB of video data in there.


No problem, let me know how it goes, x

1 Like