Blank Screen when trying to run a (crazy simple) experiment online

URL of experiment on Pavlovia: Pavlovia
URL of experiment on Gitlab: Milestones of Early Cognitive Development / PlaymoJoseph · GitLab

Description of the problem: After encountering problems running a more complex experiment online, I created a completely new project on and synced an experiment that ONLY shows a text message (no additional code, absolutely nothing fancy). There seem to be no problems synchronising.

But when I try to run the experiment online just a blank screen appears. This happens if I try to run it online via PsychoPy (button “Run the study online (with”) and also if I try to pilot it via the Pavlovia website. If I try running it online via the “runner” window (button “Run PsychoJS task from Pavlovia”), the error message “404 Not Found nginx” is displayed in the browser.

I checked that:

  • experiment name, folder name and project name are the same.
  • ssh keys are working
  • I am using the last version of PsychoPy

I tried it on different browsers (chrome and safari) and a new MacBook (2020) with the current operating system. I am NOT new to PsychoPy and I tried everything I could find in different threads on the problem, but nothing is working and I would gladly appreciate any help you could offer. Thanks in advance!

Hello KatrinR

you have a folder called index.html in your repository. Delete this folder and try syncing again. Pavlovia expects an index.html and two .js-files (experimentname-legacy-browers.js, experimentname.js) in the root-folder of the experiment.

Did you specify an Output path in the online tab of the Experiment properties? If so, leave this line blank.

As long as Pavlovia does not know the software platform and the platform version, your experiment won’t run online.

Best wishes Jens

Thank you SO much. The output path was empty, but deleting the index folder did the trick. Thanks!!!

@KatrinR - thanks for posting this. When you initially synced your experiment for the first time, did you get any kind of 403 error in your browser? I am repeatedly having this issue today. I try to add a study made in v2022.2.4 Builder to Pavlovia, and get as far as pressing ‘OK’ on the Committing changes box, then I get a 403 error in my browser, followed by what looks like the same issue you had - a folder called index.html appears in the local folder and repository and the study won’t run in Pilot / Run mode, as you describe.

I’m having other issues today as well that may / may not be linked, but could you or @JensBoelte please help me - how do I best delete the index.html folder? I can’t see how to delete it from the repository - am I missing a button / option somewhere? Help I’ve found online doesn’t align with what I see when I got into the Repository.

If I try to delete it locally and then sync again I get the following error:

Traceback (most recent call last):
File “C:\Users\clarele\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\app\builder\”, line 1369, in onPavloviaSync
File “C:\Users\clarele\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\app\builder\”, line 804, in fileExport
File “C:\Users\clarele\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\scripts\”, line 71, in generateScript
compileScript(infile=exp, version=None, outfile=filename)
File “C:\Users\clarele\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\scripts\”, line 245, in compileScript
_makeTarget(thisExp, outfile, targetOutput)
File “C:\Users\clarele\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\scripts\”, line 217, in makeTarget
script = thisExp.writeScript(outfile, target=targetOutput, modular=True)
File “C:\Users\clarele\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\”, line 286, in writeScript
self_copy.settings.writeInitCodeJS(script, self_copy.psychopyVersion,
File "C:\Users\clarele\AppData\Local\Programs\PsychoPy\lib\site-packages\psychopy\experiment\components\settings_init
.py", line 857, in writeInitCodeJS
with open(os.path.join(folder, “index.html”), ‘wb’) as html:
PermissionError: [Errno 13] Permission denied: ‘C:\Users\clarele\OneDrive - Edge Hill University\Package 3\Pilot_Valence_Task\index.html’

Thanks both!

I deleted the html folder in my local folder on my Mac and I checked in PsychoPy under “Settings/Online” that the entry “Output path” was empty (the entry was html although I am pretty sure I did not select that, but it might be an issue when changing from an older version of PsychoPy to the newest one). Then, I synchronised my experiment to Pavlovia and it worked. I was not able to repair the more complex version though and I decided to rebuilt it step by step (which makes sense in my case as this more complex experimental version was built with a much older version of PsychoPy). I hope this helps and you can resolve your issue soon!

Thanks! I’m following the same process as you in that case, only I am not able to re-sync my experiment once I have deleted the folder. I’ll see if I can find out why that might be the case :slight_smile:

Hello rpawling

delete the index.html-folder locally and sync again. AFAIK, online you can only delete files from a git-repository, not folders.

You could try to delete the folder using git itself, see

BTW, I have seen that you have your PsychoPy-experiment on a onedrive. cloud-based storage and git don’t seem to run along well. So rather store your PsychoPy-experiment not in your onedrive (google drive, dropbox, aso.) and rely on the syncing via git to move an experiment from one computer to another.

Best wishes Jens.

Thank you! I have indeed been working on it with a PhD student, on a university machine where we have to use OneDrive. I will take yours and KatrinR’s advice and try moving the experiment to a new machine where we can build it on the hard disk. I’ll have a go at this now. Thanks so much for the guidance on dealing with deleting the folder. I’ll report back on how it goes.