Experiment is stuck on "Initialising the experiment"

URL of experiment: https://run.pavlovia.org/mykolasss/belenkaaa/html/?__pilotToken=45c48cce2e2d7fbdea1afc51c7c6ad26&__oauthToken=a8d4af564284394dedf2a3955a681a848e926235b36132908511a2b11f6595a5

Description of the problem: Hello, I managed to sync my experiment, but it’s stuck on “Initialising the experiment” when I try to pilot it. I tried troubleshooting, but I can’t understand what’s the problem here:

Hi There,

is there a file in your repository called “nameOfExperiment.js” - it looks as thought he javascript file might not exist/ may have failed to be written. If this is the case, look in the std out window of runner view when you hit sync and there should be some information on whether the .js file failed to be written.


Yes there was a file “nameOfExperiment.js” in the html folder, runner didn’t show any errors. I tried updating psychopy to 2021.1.3 and it seems that the experiment synced successfully, it’s hard to guess what was the problem. Although I tried piloting the experiment and it showed that radio type is not supported, I guess it’s because of the form component I added. So my question is, what form types are supported in pavlovia? I haven’t managed to find any info on that :confused:

Aha ok yes so if you are using forms online you will need to replace “radio” with “choice” in your excel files (that will function the same locally and online)


Thank you! And I have another question, in the component form I chose free text, but it’s syncing like this: image
I didn’t even wrote those “Yes, No” options, and it’s not letting me type anything in there. And another question about choice responses, I wrote 6 available options and formatted them horizontally, it looks good offline, but whenever I try to pilot online, the responses are formatted vertically and the dots overlap each other. I tried adjusting response width in the excel sheet where the questions are, but it doesn’t seem to change anything online. The URL of my experiment: https://run.pavlovia.org/mykolasss/bala_zino/html/?__pilotToken=c20ad4d76fe97759aa27a0c99bff6710&__oauthToken=a8d4af564284394dedf2a3955a681a848e926235b36132908511a2b11f6595a5
Thank you for your help

Hi There,

OK this is a bug that we are aware of and was reported by others this morning. The solution is to use a legacy version of psychojs Typed text in Text box doesn't appear in Pavlovia - #6 by Becca

In short, go to the publicaly linked repo I shared there and take a copy of the “custom-lib” folder and add it to your experiment. Then follow the stages in the linked post to manually export a html and edit the first set of lines so that the custom library is used instead of psychojs 2021.

Hope this helps!

Thank you for your help! I’ve done the procedure, but when I try to pilot the experiment, it returns the following error: " TypeError: state.toLowerCase is not a function". Could I’ve done something wrong? URL of experiment: garsinis_screenscale [PsychoPy]

I’m afraid that the editable text box is not compatible with Array.prototype.append = [].push; in code_JS.