psychopy.org | Reference | Downloads | Github

Experiment Freezes on Start-Up in Win 7 Pro but not Win 10 Pro

OS Windows 7 Pro
PsychoPy version PsychoPy3 (3.1.5.)
Standard Standalone? (y/n) yes
What are you trying to achieve?:

In my experiment, I combined some compiled builder code with the original code of a prior experiment. The whole thing was built and pretested in Win 10 Pro (PsychoPy 3.1.5.).

I would like to run the experiment on Win 7 Pro (PsychoPy 3.1.5.). But after I start the experiment from the coder window and enter the experiment info, the screen turns black (experiment background color?) and I can only see and move the mouse cursor. The experiment does not appear to start.

What did you try to make it work?:

  • I tried clicking around and pressing the keys that are meant to be activated on the intro page. Psychopy then immediately freezes and needs to be shut down with force.

  • I tried not running it full screen. Here, two windows are opened. One of them just flickers and disappears (C:\Windows\SYSTEM32\systeminfo.exe). The other one then behaves like the fullscreen version above.

  • I noticed that I get two separate monitor specification warnings. I thought that maybe one was an artifact of the builder code I inserted, but could not find any specifications that matched “[800 600]” and only one specification of visual.Window() in my code.

3.5796 WARNING User requested fullscreen with size [1920 1080], but screen is actually [3840, 2160]. Using actual size
7.2886 WARNING User requested fullscreen with size [800 600], but screen is actually [3840, 2160]. Using actual size

  • I cleaned out userPrefs.cfg and appData.cfg as suggested here. No difference.

  • I went back to Win 10 and noticed that:

  1. endExpNow needs to be set to False for the experiment to work. If it is set to True, the experiment quits to the coding window after displaying the initial psychopy logo.
  2. When running in fullscreen, it takes a couple of seconds for the experiment to be responsive to the input keys defined for the first page.
  • Initially, I also got the error message telling me that msvcr110.dll was missing. This was fixed by downloading and installing the necessary runtime components.

Thank you for your ideas and help! :raising_hand_man: