psychopy.org | Reference | Downloads | Github

PsychoPy3 on Windows requires MSVCR110.dll

I wrote two experiments using my Mac in PsychoPy3.0.6 but when running them on a Windows PC, I get the following Error message:

Error%20Message

It translates to “The program cannot be started, as MSVCR110.dll is missing on the computer. Reinstall the program to fix the problem.”.

I did some research and found that MSVCR110.dll belongs to the Microsoft Visual C++ redistributable 2012. I installed it and rebooted the PC but the message still pops up.

The funny thing is that after closing the error popup, I can run the experiments as expected. As I am using the terminal / a batch script to call the experiments, that does not work, though, as the batch-script simply moves on to the next line.

One other aspect I do not understand is that I believe that when testing one of the experiments on the computer, I did not have any problems with that error message in the beginning. It only occured today. I might have a false memory here, though, and it might never have worked at all. I cannot imagine anything I changed since then.

Trying to uninstall and reinstall PsychoPy3 did not solve the problem, either.

Thank you very much for your answers!

1 Like

I got the same problem. Thank you for the answers below.