Excel file not read completely

Dear all,

I have the following problem and I have no idea how to solve it.
First of all, I must point out that the experiment runs perfectly on Psychopy and it also runs online using Pavlovia - no error or other types of problem appear when I run it.

I have two loops in my experiment (it is a crosslinguistic priming task with picure description)
The first loop is for the practice and it is composed by two routines (one with a sentence to read and type out and one with an image to describe). The second loop is the actual trial (filler-prime-image). Basically, when I run the experiment on pavlovia, the first routine in the practice loop (the filler one) is always skipped and the same happens when it comes to the trial: the first filler sentence does not appear, whereas all the other sentences in the same Excel file appear perfectly.

I am not an expert using JS or Python, but I checked and it seems the syntax for each routine is the same (as I actually copied and pasted every time).

I hope I’ve been clear enough and any help will be more than appreciated!



Dear Ilaria, thanks for the detailed description. Sorry to hear your study does not work as expected. To better understand the problem, would it be possible to share parts of the code in question or ideally Pavlovia links to your study? Here to help!

Thank you for your answer!
Of course, here is the Pavlovia URL https://run.pavlovia.org/IlariaVenagli/list1_pilot/html

Most parts are written in Italian so, very quickly, the task should be to read and copy a filler and a prime in Italian, then to describe a target picture in English.

You may notice that at the beginning I’m showing an example which skips either the image or the sentence, and when the actual trial begins, the first filler sentence misses (in fact, only one sentence and one image appear at the beginning, whereas it should be two sentences and one image).

OK great, that is really helpful, many thanks for your patience while I investigate further :slightly_smiling_face:

of course, thank you for your help! :slight_smile:

Here is the updated link


Thank you again :slight_smile:

Hi Ilaria, thanks for holding. Sorry, for some reason that link will not open for me (404) :thinking: Is it still active? Would it be possible to send me the .psyexp instead?

Hi! I am sorry for being so late. I actually have been working on that all day till I figured out that the problem was due to the KeyBoard input.
It seems to be working now, I hope I won’t get other problems later.

In case you’re curious, I am happy to share the link :slight_smile: https://run.pavlovia.org/IlariaVenagli/pilot-3/html


Ah cool, that is great news. Please post back if you come across anything else, here to help. Happy coding! :sun_with_face:

Hi, Ilaria, do you mind sharing how you solve the issue? I also ran into the same problem and I inspect the problem to be with the KeyBoard as well. Thank you!

Dear Kuriko, sorry for the late reply.
Sure, I will try to be as clear as possible.

I had two subsequent routines in my experiment, both of them having “press enter to end routine” as a command and the second being inserted into a loop (24 repetitions). I still don’t understand why, but the problem seemed to be connected to the fact that I was using enter in both routines (i.e. it was skipping the first screen of my second loop-routine). However, when I changed the first routine settings and used the right keyboard-arrow to end the routine, the problem was solved. For the sake of simplicity:

  • Routine 1: right-arrow = end routine
  • Routine 2 (in a loop) : enter = end routine
    In my experience, they must be different. Yet, I don’t wanna sound overconfident. Hope to have helped you.
1 Like

Hi, Ilaria:

Thank you so much! I will sure to investigate it later.