psychopy.org | Reference | Downloads | Github

Error with playing of sound in online experiment

URL of experiment:

Description of the problem:

Hello psychopy-community,

We are currently running an online experiment through Pavlovia and we have already tested some participants. However, one of our participants encountered the following error and we have not seen this error before. We also couldn’t find anything about this error online. The experiment is run on Google Chrome and we have already had some successful sessions. I am reluctant to paste te URL in to this question, because the experiment is currently running and we have no control on when participants will complete our experiment, so I don’t want to interfere with any sessions going on at the moment.

TypeError: this._volumeNode.toDestination is not a function

Anyone knows what this error means?

Hi @esijye, thanks for flagging, would it be possible to send me a link to your project so I can take a look at the code? Thanks, s.

Hi @sotiri

Yes, here’s the gitlab link: https://gitlab.pavlovia.org/Rianne/spanishwblijst1

I set it to public.

It is super strange, because now that I run it myself, it also gives the exact same error. Before testing, we pretested all our lists several times and everything went fine - so I don’t understand why this error is happening all of the sudden! Your help is greatly appreciated since participants might not be able to start our experiment at all now…

Hi! I am having the same issue with my online experiment too that is in full force RUN mode! I have run close to 30 subjects already and I have not had an error until today with the same issue (see image of issue attached). @Becca have you heard about this?

Here’s my gitlab link: Sign in · GitLab

This is very odd! Hope someone can help.

1 Like

Yes, me too. And I have participants lined up this week, who are supposed to participate in our study. They are also not easy to find…I guess this is now a general bug in Pavlovia, because I just saw another post about this. Relieved we are not the only ones going through this, but timing is very unfortunate…

Same here only today after 345 runs with no error…
open the link on Chrome or Mozilla

1 Like

Same here. The experiments worked fine, but then suddenly stopped. What kind of error is it? Would pushing the experiment to Pavlovia again work?

Same problem here. Error message attached. Any help is appreciated, thank you!

Dear @rosem09, @omaxwell, @mbv0, @bbuniv, @esijye, sorry about this :blush: Just added a PR to address the issue and expect to have it merged in the morning. Please let me know if you need me to create temporary patches until then for any of your studies. Thank you, x

2 Likes

Thanks @sotiri!!

in the mean time @esijye this version has a patch that I think should provide a running version of your experiment ? (I was playing as this issue affected one of my exps too!) https://run.pavlovia.org/lpxrh6/spanishwblijst1/html if this works feel free to fork it (but it looks like sotiri may have implemented a more permanent fix that should be in place tomorrow :slight_smile: so if you can wait for that it may be the fastest/easiest solution)

1 Like

Hi @Becca and @sotiri. Will this merge address multiple studies or just @esijye 's study? Let me know how I can help or if you need access to my study. Still running into the same error.

Hi @rosem09, yes a permanent fix is on the way, x

1 Like

@sotiri you are a life saver!

@rosem09 No problem, thanks for your patience :blush:

2 Likes

@sotiri Thank you so much! Will this patch fix the experiments automatically, or will we have to re-upload our experiments to Pavlovia?
Thanks again for addressing this so promptly!

Thanks @mbv0, yes it should fix them automagically :wink:

I have the same issue :frowning:
Until yesterday, there was no problem at all.
Please give me advice to fix this problem.

Just want to get on this thread as well…I’m experiencing the same issue. Will keep an eye out for the fix!

@sotiri and @Becca, thank you both for the prompt responses, happy this platform is around :slight_smile:. I’ll wait for the general fix of this morning as I had 11 other lists running and not just the one I uploaded here. Looking forward to the fix :slight_smile:

Dear @Becca, @esijye, @omaxwell, @jsamper, @jini0930, @rosem09, @mbv0, I believe the fix is now in place, could you please double check sound is back to normal? Thank you, x

1 Like