psychopy.org | Reference | Downloads | Github

Pavlovia Experiment - Stuck on loading

**URL of experiment: https://pavlovia.org/run/maxnni/csfp_v1-06_p2/html/ **
Operating System: Windows 10
Psychopy version: v3.03

Description of the problem:

I have designed a basic trial version of a change blindness flicker task that runs fine on my local Desktop. After uploading & activating on pavlovia to test functionality, the screen becomes stuck on loading the experiment.

In the console I am getting two errors:
“failed to load resource: the server /run/maxnni/csfp_v1[…] responded with a status of 404 ()”
“failed to load resource: the server /run/maxnni/csfp_v1[…] responded with a status of 404 ()”

[Image below]

All relevant files appear in the GitLab.

I am a first time user of both psychopy & pavlovia and have no prior knowledge of javascript & java, after browsing similiar issues on google / discourse I was unable to find any associated with psychopy.

Custom Code components are included in the study

Kind Regards,
Max

Hi Max,

The issue seems to be around naming of the JS file and the experiment. It looks like the html file is referring to a file called:
MurphyFP_1.05 14.04.2019.js
but the appropriate JS file is actually called
FP_1.06_P2.js

I think this might be an issue with Experiment Name versus experiment file name that we’ve now fixed (along with various other improvements) so it would be worth trying with a newer version of PsychoPy (e.g. 3.0.7) regenerate your html code and try pushing back to pavlovia.

let us know if that doesn’t help
Jon

I just had a student with a similar issue–posting in case it helps anyone else. They updated to the most recent version of PsychoPy and re-synced to Pavlovia, but still was stuck on “loading the experiment…”

The original .psyexp filename (from Builder) had a space in it, so the corresponding .js files did, too. I thought that might be the issue, so the student renamed and re-synced. Still stuck. Then I found this post, and based on it, we went into the index.html file and found that the pointers to the .js files both started with “./” even though the .js files were in the same folder as index.html. We manually removed “./” and now it works just fine.

I’m not sure exactly where the folder-level discrepancy came from, but just in case someone has a similar issue, thought I’d post it!

Thanks for reporting, I had the same name issue, but manually changing it did not help.

I had the same loading issue. First, I changed the .js filenames in the Index file as suggested by @jeffbye above. However, it did not help. Then, in Chrome output, I noticed that I actually had a simple syntax error in my code element. I fixed it, and experiment started working. So, seems that different problems may lead to this “loading the experiment…” issue.

If you find a syntax error coming from the Builder-generated code ten let us know so we can look fix it more generally. Similarly, if the files are including “./” in file paths unnecessarily then we’d like to know when/why that’s occurring.

Providing links to your experiments (when they’re broken) really helps us look at an actual broken example and find the fixes.

thanks!

Thanks, @jon. I had another student with a similar issue as well. I will ask them for their permission to share links with you (presumably by direct message if possible).

I don’t know if this will add any context but I recently updated from Psychopy 3.0.7 to 3.1.0 and I now get this error; but only after I moved the experiment file to a fresh new folder (i.e. the same experiment file works in the folder where the files were created in 3.0.7 (or older actually) but not in a folder where the requisite files were created in psychopy 3.1.0).

I should note that the experiment that successfully loads still doesn’t work but that’s due to a separate issue involving variable positions.

Loading error experiment - https://pavlovia.org/run/Jbroome/test/html/

Copy that’s ‘working’ - https://pavlovia.org/run/Jbroome/do-cognitive-style-and-mood-mediate-attention-toward-emotional-faces/html/

Hi @JackB, I cannot see any JS files when I attempt to load your experiment. This used to happen when users changed the name of their experiment name (in experiment settings) so that it did not match their filename of the psyexp Builder file. However, this was fixed. Would you mind sharing your repo so I can see what is happening?

Hi @dvbridges, sorry I’m not sure what you mean by repo (repository? - the .gitignore file?), I’m fairly new to this program. I am though, happy to share whatever files will help.

I should mention that all my written code (which is relatively little) is in in python as I haven’t been able to convert it to JS yet.

Apologies! I mean your Pavlovia project repository that contains your files for your experiment. If I can see this, I can get an idea of what you have done, and why you are receiving these errors.

Ah I see, unfortunately when I try to access Pavlovia I get the ‘Error when fetching the experiments’ message; and upon attempting to re-login I get the ‘Error 500’ message, so I can’t link anything from the Pavlovia server. Perhaps they are all related as I haven’t had any of these issues before?

If there are any offline files I have which may be of use to you which I can upload, please let me know.

Thanlks @JackB, there was work taking place on the server, but should be up and running now.

Ok thanks for the update @dvbridges , I can safely login in now. I wasn’t completely sure how to do this, so I’ve invited you (or whom I assume to be you - ‘dvbridges’) as a guest on Github.pavlovia. If there is an alternative way that is easier or you require higher access just let me know. Please ignore the commit names, I was debugging lots of small things.

Writing this I’ve realised my experiment isn’t set to public, I can do this temporarily if it’ll help.

Lastly, my other experiment which was working is now stuck on loading experiment, and the only things that have changed is the ‘lastrun’ python file and the ‘data’ folder from offline testing. If you need access to this one just let me know.

@dvbridges @jon Hello, I have several studies running for weeks now. They all had been working well and I did not make any changes to any of them. Just today, my participants notified me about getting stucked at “loading experiment” as described by @Max_Murphy. I’ve read all posts related to this error and tried, for example, getting rid of parenthesis in a code component. Yet, it still gets stucked when trying to run it online, (works perfectly on my computer).
I have no idea of what to do, also cause I am only familiar with creating experiments with the builder and not using the code console. Is it possible that it is only a problem with the server and it will be solved in the next days or is there anything I can do from my side to fix this?

The study I edited about the parenthesis in the code component is this one:

https://run.pavlovia.org/karena/control-l1/html/

And I created all experiements with PsychoPy v3.0.7

I would really appreciate any suggestions!

Thank you

Hi @Karen_Arellano, looks like there is a typo in one of the PsychoJS libs (util-3.0.7) where a docstring comment has been replaced with a ‘u’. This will need fixing by @jon or @apitiot.

Hello @Karen_Arellano,

We made some substantial changes to the Pavlovia server and back-end over the week-end. We endeavoured to do so with minimum interference so experiments could continue running. Inevitably a couple of bugs slipped through the cracks, which affected some people.
The issue has been resolved and I can confirm that your experiment is running fine.
Many apologies for the interruption!
Best wishes,

Alain

@dvbridges @apitiot I understand. So many thanks to you for your time!
I really appreciate your help!

Greetings,
Karen

Hi! Looking into this issue because one test run of my experiment (https://gitlab.pavlovia.org/naomilee/num-abb) ran into similar looking issues.

(Honestly, I’m not sure it is the same, since all but two pilot runs have completed and saved successfully. And the one pilot participant with this problem actually reports being able to go through a few routines of the experiment before the screen returns to “initialising the experiment” and throws an error: see below.) If anyone has any leads as to what might be going on here, such that most machines are running my experiment fine but one person would run into this error, I’d be much obliged!!

But in case the index.html file or something about my experiment naming is somehow at fault, I’m hoping to clarify three things:

  • Please correct me if I’m wrong! But doesn’t “./” reference the very same folder that you’re currently in? So if index.html is referring to my .js files from within the html folder on my repo, isn’t that correct (if unnecessary)?

  • Regardless of whether or not the “./” bit of the index.html file is doing anything there or not, can I ask - @jon, was there actually an issue in the way Builder was generating code here, and if so, has it been changed?

  • Finally, I’ve seen reference to spaces in one’s experiment or .psyexp name(s), or mismatches between Experiment Name (in Experiment Settings) and the .psyexp file name creating somewhat similar-looking errors. Would a dash character (like the one in “num-abb” - incidentally the name of my own experiment :sweat_smile:) cause any similar issues? And if one were to want to rename one’s experiment in all the relevant places, would changing the .psyexp file name manually from your local computer, then opening Builder and changing the Experiment Name in Experiment Settings to the same name, be sufficient? As in, would that automatically change the experiment name on gitlab / your Pavlovia experiment page, too? Or are there more steps to make sure everything ties?

Many thanks!!!

Tone.min.js:1 The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page. https://goo.gl/7K7WLu
s.default.Context @ Tone.min.js:1
Tone.min.js:1 The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page. https://goo.gl/7K7WLu
s.default.Signal @ Tone.min.js:1
/favicon.ico:1 Failed to load resource: the server responded with a status of 404 ()

That’s true in a local file system, but not true in a URL

I think not. Hyphens are permitted in URLs

But I don’t think that’s the error message you’ve got. The text of the error message says “The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page”

That doesnt sound like an error where the file couldn’t be found. This sounds like a security issue on the participant’s browser that prevented sounds being auto-played. Does your study have a sound before the very first screen click maybe? Could you add an instruction page that required the participant to click the screen to continue and only play the sounds after that?