psychopy.org | Reference | Downloads | Github

Disable Configuration wizard

The PsychoPY2 installs fine. We are currently creating powershell scripts. I did create a powershell installation script for PsyhcoPY2. It was successful. However, when the program is opened, the configuration wizard appears. We do not want this to show. We are planning to deployed the software program over 1200 computers. Will you be able to assist me?

We don’t have a ‘site-wide preferences’ at the moment, only a per-user preferences but this is the sort of thing that I guess we need a system preference for.

The two workarounds I can think of for you are:

  1. Remove the code form the application that launches the wizard.
  2. Make PsychoPy think that the user has already run the application before.

Method 1

To do this you need to find the file _psychopyApp.py and simply remove the lines (around line 185):

        if self.firstRun and not self.testMode:
            self.firstrunWizard()

The downside of the method is that when you ext update the lines will obviously reappear (if we haven’t by then found a better solution to the problem)!

Method 2

When PsychoPy has been launched and quit at least once a file appears at ~/.psychopy2/appData.cfg and what triggers the startup wizard to run is the absence of that file (specifically the absence of a valid ‘lastVersion’ setting within that file). The file also stores the history of files you’ve had open and where windows were positioned.
If you were able to populate your user accounts with a valid appData.cfg file when their accounts are created then this would solve the problem more cleanly.

Hi Jon,
Thank you so much for the information… I found Method 1, but I unable find Method 2. I’d recently updated to 1.85.2 on one test computer. I could use Method 1, but I feel that Method 2 would work better.

thank you,