Default OK button that appears at the end of an experiment in Pavlovia not working

URL of experiment:
https://run.pavlovia.org/TSKang/jointsimoncompletewin84/html

Description of the problem: I have begun pilot testing and everything in the experiment is working fine. However, when my brothers went which is the end she was unable to click the okay button, and pressed escape instead. This meant that no data was saved. This is not an okay button that I have programmed as part of the study, it is the one that appears by default at the end of the study in the Pavlovia Interface.

I have the save incomplete results tab toggled on, but this does not appear to have made any difference.

One thing that I think might potentially be a fix is to follow the advice from the cribsheet and insert the final routine requiring a key press at the end. I have read this, but even that necessitates the appearance of the okay button in the interface.

Thank you in advance for your help!

What version are you using?

Sorry! 2021.1.3

Thanks. Probably not a version bug then,

I think that the okay button being greyed out would be a sign of the credit no longer being available either because the experimenter has released it or because the participant took over 12 (24?) hours to complete.

Any thoughts @thomas_pronk ?

Wow, those are some good-looking instructions! I’m not sure what’s up here, but I’ll ask around. I’ve got a general suggestion though. When collecting bug reports from participants it’s handy to get as much detail as possible. Here is a little guide I wrote for that purpose: https://thomaspronk.com/pdf/Tech_Support_and_Bug_Report_Guidelines%20v1.3.pdf

Well my department has a site license so we don’t actually have to allocate any credits per se. I will ask my participant for additional details as indicated in Thomas’ guide. I certainly hope she didn’t take longer than 12 hours!

My participant has the following info as requested by the bug report guide:

"I did the task in one go in less than half an hour.

I ran it on my laptop with a Windows 10 operating system and Microsoft Edge browser.

There was no error code - I was just stuck with not being able to point my cursor (either on the laptop itself or my remote mouse) at the OK button on screen."

Might they have lost Internet connection either during the experiment or at the point of finishing it?

  • Was the pointer visible?
  • Could they click anywhere else?
  • Which color did the dialog box around the OK button have?
  • Was there any text that went with the OK button?
  • When they closed the browser, did anything noticeable happen?

I don’t have this problem myself because i just know to right click to see the pointer. I hid it at the beginning of the study I have now added a code component at the end of the study to show mouse again. In begin routine i have `Preformatted // win.mouseVisible = True// on the py side and and //document.body.style.cursor=‘auto’;// on the js side

but i now get the error:

  • ReferenceError: win is not defined

Are you defining win in code_JS or PsychoPolyfill as per my crib sheet?

I’m not sure what you mean. I have added the special code component to the beginning which only has the code about polyfill. But now I have my experiment stuck on initialising for a very long time. And I can’t find any mention of defining win. I have tried to search by keyword through the text of your crib sheet. Apologies if I’m missing something obvious!

win gets defined in the polyfill.

Is your experiment crashing at the start or the end?

If PolyFill seems to be increasing the time it takes to initialise, please could you report the times with and without.

Without the extra routine for polyfill , my experiment loads almost instantaneously , as it always has. However when I add this extra component it takes so long to load has to make me believe it’s never going to load! The crash occurs at the last routine when I have the code to make the mouse pointer visible again. This should make it possible for my participant to clearly be able to click on the okay button at the end. No?

Please could you let us know a bit about your Browser.

In the meantime, you should be able to replace the polyfill code with win=psychoJS.window; in Begin Experiment (if that’s the only aspect of it you need)

I’m using the latest version of Edge.

1 Like

Hmmm… interesting to read the PolyFill might be giving an issue. Please keep us posted!

Just settled on using the single line of code that Wakefield pointed me to. Now everything is running perfectly fine. Something about all those functions needing to be loaded and used at the same time??

Weird; we’ve added the Polyfill to our testing battery and it all checks out. Also simulating a slow connection doesn’t make it trip.

Could you indulge me and run the experiment below? You should briefly see a text saying “Running tests”, then a yellow “Closing session” dialog box, and after a couple of seconds the green dialog box saying “Thank you for your patience”. demo_polyfill [PsychoPy]

I just had a go and the running tests was a couple of seconds on Chrome.

However, on IE it’s still initialising (with no error in the console)

Update errors in the console on reload.