psychopy.org | Reference | Downloads | Github

Data folder missing from the GitLab Repository

URL of experiment: https://pavlovia.org/run/Topor/ready-go-gng-task/html/

Description of the problem: Hi all. I am using PsychoPy version 2020.2. Recently updated it as well to see whether it would fix my problem.

I have been running my task online since October without any issues together with another task. I regularly sync the tasks with GitLab to download data and clear the data folder. There are no issues with the first task at all. For the task above, I realised that the data folder on GitLab disappeared. I thought that no data was coming through but I got emails from participants that they have done the study. I managed to download their data by pressing the button “download results” on Pavlovia, but this is not an efficient way for me to continue as I need to regularly delete the data coming in to keep an eye on new entries.

Any idea why the data is not depositing on GitLab any longer?
How can I access the folder of the data stored under the “download results” button?

Thanks!

Update:
Some odd things are happening and I am not sure what to make out of it.
Firstly I see that on Pavlovia, PsychoPy version I am using for this task has not been updated.

Secondly, the issue is now fixed, I deleted the JS and HTML files from the study folder and synchronised. Normally, it should generate and push updated files but it didn’t. The html folder only has “resources” in it and nothing else. Yet the task still works and all the data now saves to GitLab again.

I think there is an issue with syncing the files somewhere?
Can anyone understand what’s going on here?

Update 2:
The task doesn’t work at all now, the situation is quite desperate!

I was informed by a participant that the task stopped working. I realised that it only worked in my browser as I had all the cookies still in the browser.

I removed the cookies and when I try to run the experiment I get the following error (from Pavlovia or PsychoPy, the error is the same) :

Failed to load resource: the server responded with a status of 403 ()

I have reverted all the changes I made. Put back in the HTML files I removed and changed back PsychoPy version to 2020.1. I synchronised it with the repository but the same issue persists.

I have tried to export a new html file and I think it worked as there is a new html added to the repository. After deleting cookies again and trying to run the task, the same error persists.

I have tried to quickly copy the file and make a new repository to see if this would fix the bugs but the same 403 error persists.

I am going to email my participants to let them know that the experiment is broken and not to complete it just yet. In the meantime please, could someone have a look to see if they can spot what might be the issue/solution? No idea what to do.

[SOLVED]
Update 3:
I realised that the error occurred as a result of having the “lib” folder included in the HTML folder. It was an old folder that did not get updated and it seems that files inside were not needed.

I deleted the folder and the task works and all data is synchronising perfectly now.

My goodness, what a scare!

Any comments/explanations on my mistakes above are welcome :slight_smile:

1 Like