psychopy.org | Reference | Downloads | Github

Missing participant data when downloading files

URL of experiment: task_2 [PsychoPy]

Description of the problem:
Hi everyone,

I just realised that when I try to download the results of one of my experiments (both from pavlovia and from the gitlab repository), I’m (probably) missing the results from one participant. I suspect this because I know I received new results on the 24th of September that I tried and failed to download (I couldn’t find any recent file), and then I received new results on the 26th which I downloaded successfully.
I saw similar posts but I didn’t manage to figure out a solution. My question is how to go about solving this (because results from one participant are crucial at this point of my study), and if it can be the case that results have been overwritten if the participant who performed the task on the 26th was the same with the one on the 24th (in other words if that person answered twice).

Thank you in advance, your help is really valuable :slight_smile:

The should be unique data files for each participation event, even if the participant number is the same. Have you checked the data folder on Gitlab? Are you saving to CSV or “database”?

I am saving to CSV format and I have checked on Gitlab, but I couldn’t find any data file created in September other than the one from the 26th.

How do you know you received new results on September 24th? Might the participant have failed to finish?

Are you downloading by syncing and then deleting the files from the data folder or leaving them there?

I know I received results because I saw on Pavlovia that the number of sessions changed and the date of the last sessions was the 24th. I didn’t download them directly, and when I got a new response I tried to download but I could only see the most recent one.
I am downloading by pressing the “Download results” button on Pavlovia and I leave the data files there after downloading. I’m also saving incomplete responses, so even if the participant didn’t run the experiment to the end, I should still receive a data file.

Unfortunately, saving incomplete data doesn’t always work

I see. Thanks for your time :slight_smile: