psychopy.org | Reference | Downloads | Github

Data don't save on Pavlovia Data file

URL of experiment: https://run.pavlovia.org/Zhaleh/fullexperiment/html

Description of the problem: I run the experiment both directly from pavlovia and from Qulatrics to Pvalovia and in either cases data don’t save in the data file. What should I do to solve it?

1 Like

Are credits being consumed?

Are you saving to CSV or database?

Are you getting the green “Thank you for your patience “ message?

What are you doing to look for the data?

Are you getting log files?

Hi @wakecarter
Our university provides us with license for Pavlovia so I don’t need to use credits.
I save a CSV.
Yes, I get the green “Thank you for your patience” message.
I go to the data file on pavlovia but just data for a week ago are there.
What do you mean by log file? Where is that?

The log files are stored in the same folder as the CSV files. For database saving you only see the log file. What version are you using?

Hello, I have the same problem. In the last three weeks I runnned 12 experiments, among these 6 data subjects have not been download. I dont’know where the problem is.

1 Like

Please could you delete your new thread and put full details here if you think it’s the same issue?

Hi, we have the same issue in our experiment, our university provides us with license for Pavlovia so I don’t need to use credits to, we save in CSV, the green text “Thank you for your patience” appeared. We tried to run the task before the participant, and a data file download correctly for us, but not for the participant.
Do someone know why this happen? And have a solution?
Thank you for any help

1 Like

If the participant is using the live link, are you getting anything saved in the repository?

Hi, I have the same problem reported by Zaleh, Elisabetta and Selma. Sometimes everything works and is saved perfectly, some other times the study runs smoothly but then there is no trace of it in the repository. (https://gitlab.pavlovia.org/F.Poli/cdlearning.git).

What could be causing this?

Hi, I have a similar problem where some (but not all) participant csv files are failing to save, although when we test it ourselves it always saves fine. Like others on this forum, our university provides us with the Pavlovia license.
Following to see what others say

We also have the same problem. We use SONA and participants get directed back to SONA so they have seen the green text “Thank you for your patience” message. The data file is saved but there are 3 strange things: 1/There is no participant number, 2/ The experiment name is the name on Pavlovia and not the name associated with the PsychoPy file, and 3/ Most seriously, the data file is empty. There’s no data actually saved. No corresponding credits have been consumed (but this somehow always a bit lags behind). Piloting went well, and we did experience data is not saved sometimes, but we couldnt find out when and under which conditions that happened (as it was the same experiment, using the same repo, with the same setting, and all have seen the “Thank you for your patience” text). The only thing we notice is that perhaps whenever the experiment is saved under the name associated with the Psychopy file then the data is saved, and whenever it uses the Pavlovia name then not. But then we couldnt find out when which name is used… It seemed totally random.
This is quite a serious problem and I hope there is some solution. We cannot just afford to lose data inexplicably like this.

I’ve done some detailed analysis of @Tuongvan’s data files, since they are using my VESPR Study Portal which gives a some extra timestamps and I’ve worked on their experiment.

Participant 9 (who completed the task) launched at Fri Apr 30 2021 12:05:34 GMT+0000; reached the debrief at Fri Apr 30 2021 13:05:02 GMT+0000 (one hour later) and the timestamp is 9_Tetris_B_210128_2021-04-30_14h05.44.748.csv (10 seconds after the initial launch). The data was saved at 1:03pm (after 58 minutes).

Participant 17 launched at Tue May 04 2021 10:47:47 GMT+0000 and the timestamp is 17_Tetris_B_210128_2021-05-04_12h47.53.896.csv (6 seconds later). The data was saved at 11:07 (after 20 minutes).

Participant 19 launched from my site at Tue May 11 2021 14:17:17 GMT+0000 and their empty data file is named PARTICIPANT_Letris_210201_2021-05-11_16h17.21.761.csv, which is 4 seconds later accounting for time zones. The data was saved at 2:17pm (i.e. less than a minute).

Participant 20 (me trying to save some partial data) launched from my site at Tue May 11 2021 17:36:31 GMT+0000 and my data file is named 20_Tetris_B_210128_2021-05-11_18h40.24.362.csv which is nearly 4 minutes later, accounting for my time zone, which will probably be the time between reaching the expInfo dialogue box and pressing OK. The data was saved at 5:41 (after 1 minute).

Participant 21 launched at Tue May 11 2021 19:22:03 GMT+0000. There is no data file corresponding to this participant, which suggests to me that they either closed their browser without giving time for the data file to save or are currently in the experiment (it was less than an hour ago).

The data file for participant 19 therefore dates back to the initial setup of the experiment and suggests to me that they pressed escape or cancel on the expInfo dialogue box right at the start.

My conclusion is that if a participant presses Cancel or Escape at the dialogue box doesn’t cost a credit and an empty data file is saves without a participant number and using the psyexp file name instead of the Builder experiment name in the data file.

1 Like