psychopy.org | Reference | Downloads | Github

Crashing GUI with anaconda installation

When starting to run an experiment, I get the following error:

Fatal Python error: (pygame parachute) Segmentation Fault

This is on OSX 10.10 & 10.11 using version 1.85.1. I’ve read through quite a bit, tried reinstalling using anaconda, tried swapping libraries, etc., all to no avail. Any help would be greatly appreciated.

Thanks in advance,
David

I’m assuming this doesn’t happen with the Standalone installation on your machine? So probably something to do with your setup (e.g. a library version that’s wrong).

It is with the standalone installation. It’s happening on 2 of 3 Macs. They are all running the latest version (1.85.1). I have tried a separate installation on one of the machines using anaconda, but it had similar results, and I ultimately stopped trying as I was stuck in the purgatory of package incompatibility.

Well then I’m at a loss - I’ve installed 1.85.1 on several macs and not had a problem running programs. This happens with any experiment (e.g. the demos)? And there’s nothing else in the error message?