Committing changes screen takes too long

URL of experiment: /

Description of the problem: Hi,
I have recently started experiencing a problem where the “committing changes” screen takes anywhere from 1-5 minutes to finish loading before I can click the “OK” button. This doesn’t happen on one experiment, but on all of my experiments (I designed 10 of them) so it can’t be due to the experiment size since I have from super light to really heavy experiments in regard to their size. So, once I hit “Sync with Web” button, my mac displays the pop up window with the spinning wheel icon that takes from 1 to 5 minutes to load and only then can I actually click “OK” to commit changes. I tried freeing up laptop space, reseting the system, deleting and re-uploading the experiments but nothing seems to speed this process. This greatly decreases my efficiency so I though I better ask this question here, maybe someone has had the same issue in past. Thanks!


I have no experienced your exact problem, however most problems of this kind could be solved through empyting cache. I am linking the psychoPy troubleshooting page which I hope will be helpful.

It could also be a problem that happens due to pavlovia or browser cache which I hope this previous question helps you!


1 Like