| Reference | Downloads | Github

Coding/lib category naming

Hi, maybe it’s just my eyes or the old computer display I’m currently using, but “Coding/lib”, with the slash between the two words and the sans serif font, is not very readable to me. Would it be possible to insert spaces before and after the slash and/or capitalize the “lib”, i.e., “Coding / Lib”? :slight_smile:

I see this has been changed now, thank you!

How about these changes to category names?

  • Coding / Lib :arrow_right: Coding.
    That will probably cover 90% of the posts and of the remaining 10% who wants to ask questions about the psychopy modules (library), many will probably belong in…

  • Dev :arrow_right: Development. Unnecessary abbreviation?


I like these suggestions!

OK, if you prefer. Either of you can do that if you like. Keep the ‘stub’ the same (coder and dev). Those determine the URL of the category and the email address for messages to the category and I’m a bit attached to those short titles. The longer titles I don’t mind about as too much as long as visitors find it clear.

FYI I was originally going for Builder/app and Coder/lib as a cunning (in my mind!) way to collapse 4 different aspects of the package into two audiences (e.g. people asking questions about the app are probably using the builder)

You get an extra like for blatant use of emoji to insert a simple arrow :arrow_right:

1 Like

Done! And thanks for noticing the arrow! The small pleasures in life…

Extreme petitesse: Coding or Code?

Coding: the discussions in this category aren’t about PsychoPy code but PsychoPy coding

Ah, so we should change Builder to Building? Sorry, I couldn’t resist :wink:

1 Like

I’d go with ‘Coder’ so that it matches the software (Builder/Coder view). Not that it matters much. :slight_smile:

But you can write code in Builder and other software (I use Spyder). So I think Coding is better than Coder.