psychopy.org | Reference | Downloads | Github

Changes pushed to gitlab but not to Pavlovia dashboard

URL of experiment: https://gitlab.pavlovia.org/Crible/sprv1

Description of the problem: I’ve been working on an online experiment (to be linked to Prolific). I’m about to publish it but the final changes I made to the Builder don’t appear online. They get synced up with GitLab fine, no error message, I can see the updated time stamps on GitLab but the changes don’t reach the Pavlovia dashboard. So when I pilot the experiment via Pavlovia, I don’t see my latest changes. It’s been two hours now, and I’ve only made minor changes like adding a text routine/component, changing some text and edited the experiment info (URLcompleted, hide the dialog box).

Any ideas why? Thanks!

Sorry. Did this get resolved? If the issue is seen when you try to run the study then it’s often a simple matter of refreshing the browser cache (images and JS files get cached so they don’t have to be downloaded each time) which you can do with something like ctrl-shift-R (browser dependent). If they don’t show up on the dashboard then I’m not sure what the issue is

Thanks @jon, the changes eventually get there but after a random and usually long period of time, and it keeps happening. I’ve never had this before last week, and I do refresh the cache regularly. Could it be that the server is really busy at this time and changes may take several days to get to the dashboard?

Also, the js files on gitlab do not show the latest changes in the main folder, but they do appear in the “html” folder. Maybe that’s why?

EDIT: I see now that when I synchronize, the dialog box says “successful sync”, but the PsychoPy output keeps showing “Generating PsychoPy script…”. Again, the js file is up to date in the html folder, not in the main one

Whether it writes to the html folder or the root folder is controlled by the experiment settings (online tab). I don’t think you should ever have files in both locations - it makes it harder to know what will happen on run

I don’t think the server being too busy should be a problem at all, but maybe @apitiot has some idea whether anything has changed recently that might result in this behaviour

For the dialog box saying “Generating PsychoPy script…” I think that’s normal although I agree it’s confusing. @dvbridges we should probably add a print('OK') when that completes

I removed the js files from the main folder and now it’s updating to the dashboard properly. I probably copied them there by mistake. Thanks!

I’ve also experienced some slightly erratic updating of files from GitLab to Pavlovia, where in the former the new files show up fine, but when piloting from the latter the old versions are being used.

This is slightly crucial for us, as we need to change the stimuli between each subject (everyone having their custom made ones), and it would be good to know when they have in fact changed on the Pavlovia side also. Should it be immediate? Is the showing up of old ones basically always due to the cache issue?

In my experience, if you’re using different materials between participants, just make sure that the conditions file has a different name each time (and update it in your “trials” loop), otherwise it’s still using the older version. If you did that and still have the issue, then I don’t know what the problem could be. Otherwise in general the sync is really immediate.
Good luck!

I’m having this same issue. I made some small changes locally in the psychopy builder. After syncing, I could see them immediately in gitlab, but when I run a pilot from the pavlovia dashboard, the changes are not there. I also tried clearing my browser cache.

Ok, so I’ve found a trick that seems to be consistently working for me whenever I have changes that will push to gitlab but not show on pavlovia dashboard: from the builder I simply click on “Run study online” and after this, the changes appear immediately on pavlovia. Hope this helps!

1 Like

I am trying to understand what this answer means / how I can ensure that my gitlab js files are also updated/synced correctly. (As I assume that’s the reason for changes not appearing in Pavlovia while syncing from computer seems to work.)

Do I have to delete certain files? Or change settings in experiment settings > online > export HTML (which is currently on Sync)

Thank you very much in advance!