psychopy.org | Reference | Downloads | Github

Cedrus response box w/ PsychoPy in Mac OS: error msg


#1

Hi all,

I’m trying to use a Cedrus response box/pad with PsychoPy (1.85.2) on a Mac (OS 10.12.5).
I’ve confirmed with Cedrus that I’ve installed the right driver (according to Cedrus: VCP, rather than the D2xx driver; note that this seems to be different than what I first found in this post: Cedrus Responsebox doesn’t working )
I’ve confirmed with Cedrus (and a code from them), that in theory, PsychoPy can see my response box, but I still cannot get a simple routine to run:

I’ve tried a super simple “experiment” in PsychoPy’s builder with one routine (one text component and one Cedrus component). I’ve also tried another “experiment”, with a a second routine, where I copied the first routine and copied some code into the code component of the second routine: I tried to find and copy the start-routine and each-frame code from the button box part of the first routine into the code component of the second routine, since I read that this needs to be done for non-first Cedrus response components. (I’ve attached the code for this two-routine ‘experiment’ - perhaps I didn’t copy the right sections?)

In both cases, the program crashes and I get the following error message:

File XXX, line 126, in
if t >= 0.0 and buttonBox.status == NOT_STARTED:
File “/Applications/PsychoPy2.app/Contents/Resources/lib/python2.7/pyxid/pyxid_impl.py”, line 433, in getattr
return getattr(self._impl, attrname)
AttributeError: ‘ResponseDevice’ object has no attribute ‘status’

My question:

  1. Do I need to do any coding or add code to the code component for the first routine (if I have just one routine)? I assumed, as long as the response pad works, I can just plug the hardware in, select “Cedrus” as a response component and not have to use code.
  2. Any suggestions why I’m getting error messages in either case? Is PsychoPy not able to communicate with the box?

Thank you so much for any ideas, insights, or help!

Test_CedrusRP_2trials.py (7.7 KB)


#2

Update: a solution has been posted here (https://discourse.psychopy.org/t/cedrus-button-box-no-attribute-error/2490; cf. discussion here: Cedrus response pad implementation)