psychopy.org | Reference | Downloads | Github

PsychoPy and Cedrus Button Box - Could not find a Cedrus device


#1

Dear community,
since a long time I’m struggling to get a Cedrus button box working with PsychoPy (I’m using a Cedrus response pad RB-540). No matter which version of PsychPy I’m trying on Windows computers it does not work and I always get the error message “Could not find a Cedrus device”.

With most Macs it’s working. On one Mac computer I get the same error message, but it disappears after unplugging the button box and plugging it back again. On one Mac it does not work at all. On all machines I tried to replace the pyxid (e.g., from here: https://github.com/cedrus-opensource/pyxid) as it was suggested, for example, here: Cedrus Button Box - “no attribute” error.

My newest experience on one Windows machine: When I create a new experiment with only one text component and one Cedrus component (created in the Builder) the button box works perfectly. The same works if I loop around the routine, but as soon as I insert another routine with a second Cedrus component I get the same error message “Could not find a Cedrus device” (if the second component is text only, everything works fine). I replicated this effect with different versions of PsychoPy.

Has anyone an idea how to get a Cedrus button box working with PsychoPy?


#2

This might be quite a long-standing problem. e.g. try reading through this thread:

https://groups.google.com/forum/#!topic/psychopy-users/FIltal9nDbw

If that is still the issue, then probably filing a formal bug report at https://github.com/psychopy/psychopy/issues would be good to get this in the queue of things to address.


#3

Hi Michael,
thanks for your Answer! :slight_smile: I also tried to put in a code component as described in the thread you linked (I also tried to add a code component as described here: https://public.sharepoint.uni-graz.at/sites/psychologie/PsychoPy/Cedrus%20ResponseBox.aspx), but it still says "Could not find Cedrus device). However, maybe I try this trick on more machines.

What I don’t understand, however, is why it works on some computers, but not on others. I’ll try some more days and then I’ll fill out a bug report :slight_smile: