| Reference | Downloads | Github

Cedrus response pad implementation

Hi, I’m a (newish) Psychopy user and I’ve been trying to integrate a Cedrus RB 740 response pad in a simple priming study. However, I got this error message:

buttonBox.status = NOT_STARTED
NameError: name ‘buttonBox’ is not defined

I’ve downloaded pyxid (and the response pad USB driver) and tried to use both v1.83.4 as suggested by another user and v1.84.2 of Psychopy. I’ve never used Cedrus response boxes before and certainly not in PsychoPy, so I was wondering if you could give absolute newbie me some (detailed and written for dummies :sweat_smile:) advice for implementing the response pad through the builder view.

I am attempting to do the same thing and I get the same errors. I have also started a thread on the cedrus forum (here), but have not received a response yet. Does anybody have any insight?


The IT department where I work came to the conclusion that cedrus response pads are not compatible with Macs, which is what I was trying to run my experiment on. I’d also got through to Cedrus at one point and they said they would add a dedicated support page for PsychoPy users, but I don’t know what came of that. Other than that, I’m afraid I don’t know any more.

Thank you for the information. That is rather disheartening. I used a different cedrus button box with psychopy (on a mac) in the past. Hopefully, there is a workaround. I still haven´t heard back from tech support, but I’ll post back if I figure something out.

I have no solution, but trying a lot of combinations worked for me (so: don’t give up hope!):

I had the same problem for a veeeery long time and tried everything I could think of. I tried many different computers and versions of PsychoPy. I tried it with different operating systems (Windows and Linux systems) and in the end the following worked: I did the same thing as always, but used a Mac (it is interesting that it did not work for Irina). Suddenly, the error message disappeared and everything worked :slight_smile:

I received a response from Cedrus. They said that the issue is with Mac’s and the RB-x40 series. They are looking into it and said they will get back in touch with me.

HI all, is there an update on this?
I’m also using PsychoPy (1.85.2) a RB-740, and OS10.12. I’ve installed the VCP driver and I’ve verified that the OS can pick up the RB.
Thank you!

No news for me. Are you still working on this? Cedrus told me that the problem is that psychopy doesn’t use the newest version of pyxid. Does anybody know anything about that?

Hi! Yes, I’m still trying to get this resolved, but no luck so far. I also got a similar response from Cedrus (that the pyxis version in PsychoPy might be outdated).
Can we troubleshoot with someone who has been able to implement a Cedrus response box with PsychoPy on a Mac?
Thanks so much for any help or ideas you might be able to offer!

This thread (Cedrus Button Box - "no attribute" error) looks promising. I am trying to implement this workaround now.

I now have a working button box! I used the fix explained in the link above.

Thanks for sharing the great news! I will try this out as well! Thanks again!!

Yes, this works indeed! Thank you so much casillas.joseph for linking to the other post here and for telling us that this ended up working for you. :clap:
I will try it on my second Mac tomorrow.

1 Like

You’re welcome. I’m glad it worked out for you.