psychopy.org | Reference | Downloads | Github

Can't access data - problem with Pavlovia.org

URL of experiment: https://run.pavlovia.org/sdarling/ltmgen/html/index.html

Description of the problem: Cannot access data via Pavlovia

Hello - my study has been running for a while and contains a good quantity of data - inded it still seems to be working and saving data. However, I cannot access the data via pavlovia.org any more (was fine a couple of days ago). I can login no problem, but when I click on ‘Dashboard’ I get a long error string ending like this:

…when listing the experiments available to the authenticated user",“error”:“unable to list the designer’s experiments: TypeError: this.userIds is undefined :\n@:1:15\n”,“httpStatusCode”:500}*

If the error persists, contact Pavlovia’s administrator.

This seems to be the only way I can contact Pavlovia’s administrator. Obviously I am now worried that my data is lost - please advise what th eissue might be. I can supply more info re the error message, but as a new forum user, it won’t allow me to post more than 2 web links, and the error message contains links.

Kind regards

Steve Darling

I can access data via git it turns out, so looks like a problem with the dashboard…

This error message popped up when trying to access my list of experiments like you…

I don’t know what the problem is…

How did you access data via git?

I got the same error message when I tried to open my ‘Experiments’ tab from the Dashboard this morning. The error persists regardless of browser.
Like Steve, I can also still access the experiments via gitlab (https://gitlab.pavlovia.org).

Johanne

We’ll try and work out why the dashboard view isn’t showing the data but yes, you can access via gitlab.pavloiva.org, or by syncronizing from the PsychoPy app, or by using some git client directly

The issue has been solved. Someone’s connection to pavlovia.org was interrupted at a most inopportune time, which left a field in the database dangling. I’ve taken care of the matter, and that issue should not occur again.

Alain

2 Likes

Yes, I think every error is solved now.

Thank you for letting me know that.