psychopy.org | Reference | Downloads | Github

Cannot set experimen to Pilot, error code 502

URL of experiment: https://pavlovia.org/xywang01/identityrecognition

Description of the problem:
I have been beta testing an experiment. Before this morning, I was able to test it using piloting. However, when I tried it today, the browser console returns error code 502 when I tried to set the experiment’s status from inactive to piloting. It seems like Pavlovia cannot access my project on Gitlab. The only thing that changed was the addition of an institutional license for testing. Does anyone know if I need to make any changes to the Gitlab repository for Pavlovia to access the files after being issued an intitutional license on Pavlovia? Thanks!

Hi everyone

I tested my theory that the addition of the Pavlovia institutional license might have created the problem of connecting the Pavlovia site with Giblab by uploading the same project onto an account without any institutional affiliations and everything starts working again. I am just wondering if anyone has any suggestions to resolve this issue. Any help is appreciated! Thanks!

Michael

I am not sure at all and this is just a guess but maybe you also need to add the license in gitlab itself? :thinking:
There is an ‘add license’ hyperlink on the details page of your gitlab project.

Also make sure you are using an email address that matches your institution. This is from the Pavlovia documentation: “For our purposes, we will determine whether a user is covered by a site licence on the basis of the e-mail address they use to create their personal account. The domain name of each covered user’s address must match that of the organisation, as specified in the site licence agreement.”

Hi Julia

Thank you for your response. I actually had the issue solved by creating a new repository on Gitlab and use the new repository. It seems like after the institutional license was linked to my account the old experiment stopped working. I guess it might be a problem on the communication between Gitlab and Pavlovia.

Michael

1 Like