Cannot set experiment from inactive to piloting

URL of experiment: Pavlovia

Description of the problem:
Hi everyone, I recently finished coding my new experiment, and have been trying to set my experiment from inactive to piloting mode. However, it seems to get stuck on the updating status stage with the message below shown on my screen.

I also asked a few more people from my lab to turn on piloting for my experiment on their own laptops, but they all encountered the same problem. I have also tried deleting the experiment and resync it to a new project on pavlovia, but the same thing happened.

Has anyone encounter this issue before? If so, are there any suggestions on how to resolve the problem?

Thanks in advance!


One thing I’ve discovered is that only the project owner can change the status.

However, the other thing that can cause this issue is a serious JavaScript error. Is there an index.html and two js files in the project Gitlab?

Thank you very much for your reply. I found an old thread stating the same issue I have (Unable to change status to 'Running' - #9 by sophie_bouton), and the solution proposed there worked for me.

Basically, this issue occurs because I have an existing lib repository in my project at the time I change the status of my experiment. To resolve the issue I just need to change the name of that lib repository.


Kind regards,