Cannot download data from my experiment, stuck loading

URL of experiment: STMB [PsychoPy]

Description of the problem:
I am trying to download the results of my experiment and the page is stuck with the download results button greyed out and two blue boxes that say “preparing the results for download…” and “size of archive in preparation: unknown”. I have tried to switch my experiment from inactive back to active and that didn’t do anything. I uploaded a screenshot of the page below.

@Jon @Becca @apitiot


If you click on View Code, it’ll bring you to the gitlab page of your task. There you’ll see a “data” folder and you can download your results from there.


Thank you @suelynnmah that worked! Any chance you know how to make it work from the main screen though? Or do you think I’ll need an administrator to help me with that?

Yes if you email, one of the members of the team should be able to sort it out :slight_smile:

Hello @shannon.mahony ,

I just looked into the matter. It appears the download was indeed stuck and would automatically restart each time you visited the experiment page, thereby stucking it a little more.
I have fixed the problem. You should now be able to download your results.
With my apologies for the mishap!


Hey, I seem to have the exact same issue with the download being stuck in a infinite loop, is there a possibility that you could help me out as well or should I go on and contact the address? :slight_smile: Username is Brabender…

Hi Bradendertim,

I emailed the address and Alain got back to met pretty quickly so that might be your best bet!

1 Like

Hi Shannon, the support email isn’t generally the recommended route we would suggest here (we are a small team so we don’t have the capacity for direct one-to-one support via that email unfortunately).

This sounds like the kind of behaviour we might expect when there is a possible network error (e.g. slow internet or otherwise). Could I check if you might be expecting particularly large files? e.g. webcam data



Hi Becca,

Thank you for your response. I received a message from Jon on my other question that said that this forum isn’t monitored regularly so there is no time frame I can expect a response in. I was just wondering what I should do then if I have a pressing problem with my experiment? I did not receive an answer on any of my posts until I sent an email.

In terms of the files question, no they aren’t particularly large files (ie. no webcam data). There also was not a network error as it persisted for days in spite of everything else on our server working as well as our 3 other experiments on pavlovia were working.

Thank you!

Hey Becca,

I am experiencing the same problem. My amount of data should also be pretty small (I just have a datasheet and no media that is saved in my results), and my internet connection seems to be fine as this problem persisted for a week now.

I am currently saving my data in a database format, is there maybe another way to access the data? I cannot seem to find it in the “View Code” section.


Hi bradendertim,

When I click on view code I get another web page that automatically opens. I have attached a screenshot of what part of the webpage looks like. The page that opened automatically for me when I clicked view code was Project and then under that heading- Details. Hopefully that helps!


Hey Shannon,

thanks for your response! Unfortunately, I do not think that I can find my data there. I know the file exists but for me there’s only .log files in there and not the database .csv file that contains my results. Thanks anyways :slight_smile:

Hi Tim,

In your case, you set your projects to store data to database instead of storing to csv files, whereas Shannon is using csv files. That’s why they show up for her in the project repository but not for you

I think the next problem is just that you have very large data files. I did just manage to fetch your data but it took quite a while due to the large file sizes - your larger project contained 23,000 lines in the csv output file

I’ll email you the files I retrieved


1 Like


… Alain just managed a very substantial speed-up on this and large data files are now being generated for download MUCH faster. Your 23,000 line file is now taking about 6 seconds to compile and compress ready for download :slight_smile:

I suspect this would have been the issue for most other people that were running into issues - hopefully this is now much faster

1 Like