Builder / GUI does not open in Anaconda install (Windows 10)

I have just installed PsychoPy with Anaconda on a Windows 10 machine, but cannot see the GUI. After installation, I was met with several error messages. But after downgrading pyglet and adding libclasses, I no longer see those error messages when starting PsychoPy. Unfortunately, I also don’t see PsychoPy. It seems to start normally and displays the splash screen and a few other screens in the background. But when the splash screen disappears, so does everything else and I never get the Builder GUI. The terminal just returns to the prompt and doesn’t indicate any errors. Any idea what might be going on? Thanks in advance!

Are you installing as a local administrator? I’ve had an issue similar to this and found the working version in my admin account.

Thanks for the thought, but I’m afraid that’s not it as I’m the sole user (and admin) on the machine.

I found what seems like a very similar issue, but unfortunately this also did not fix things.

This could be a number of things, the first thing I usually try when this happens is to reset your prefs - as you’re on Windows they’ll be in:


if you delete userPrefs.cfg then when you next start PsychoPy it’ll make a new one with default prefs.

1 Like

Thanks for the suggestion. Before seeing your reply I opted for the extreme option and completely uninstalled/reinstalled Anaconda and PsychoPy. As with before, the clean install threw some errors that were fixed by downgrading pyglet to 1.4.10 and then installing dataclasses. Then, as before, the PsychoPy splash screen and a couple of other windows would appear momentarily, close, and then nothing. No errors in the terminal. I’d assume a clean install would get rid of any existing pref files, but just in case, I deleted the cfg files you suggest. Unfortunately, this had no effect.

I came across the suggestion here to determine the startup error with "C:\Program Files\PsychoPy2\python.exe" -m but I think that’s for the standalone installation and I don’t know how to modify this to achieve the same for Anaconda.

Hi All,

For those who find themselves here in the future, I have bad news and good news.

Bad news: I have not resolved the issue and and am still unable to run PsychoPy in Anaconda on Windows 10.

Good news: A clean install of the new standalone package (2022.1.1) on Windows 10 was successful and I didn’t run into the other issues that had bedeviled me with prior versions.