Wrong experiment runs online

URL of experiments:
old one: https://pavlovia.org/bartl115/bunnyonline
new one: https://pavlovia.org/bartl115/toyonline2

Description of the problem:

I have 2 experiments. I developed the first one got it work offline then eventually got it to work on Pavlovia. I then created a new experiment and it works great offline. I have synched it to Pavlovia and it shows up in the list of experiments but when I run it, it runs the old experiment instead.
Is there something I need to clear to make it point to the right experiment?
Also is there a way I can change the link to it somewhere?
All of my experiments share the same folder on my PC so when they are synched to Pavlovia they both contain the full set of files. Could that be the issue?

Any help is appreciated.

Thanks Phil

Not sure I can help you, but in any case, I cannot see your links;

“No information available for this experiment: it may not exist or you may not have access to it.”
That may just be me.

Also, I assume you have disabled the cache in your browser?

I assume you cannot see the links because they are not yet public. I believe I can just share it with you but do not know how to do it.

I have gone into the browser to clean up the cache and to erase the browser history but I did not disable it. I am using chrome and do not know how to disable the cache.

I have cleaned up the folder on my PC to only contain the files for the experiment. I then resynched and the files for the old experiment no longer show up but the old experiment still runs instead of the new one.

OK sorry but I’m pretty new here - this is all I’ve got. Don’t want to lead you down a rabbit hole, so better to wait for a more informed reply

Thanks anyway.

I have gone into developer mode on Chrome and cache is disabled while in developer mode and ran the experiment again but still the same issue.

Hi @pgerhard, you should use separate folders for each task, but also make sure that you do not nest experiments in the same folder. Folder structure should be something like:

-- experiments folder (containing only folders to other tasks(
  | -- task 1 folder
       | -- task.psyexp
  | -- task 2 folder
       | -- task.psyexp

Best option would be to create this folder structure and start again. Btw, I cannot see any experiment files uploaded to your gitlab, maybe I do not have permission to view.

This was phil B’s question - but thanks for the answer. That cleared up a question of mine as well!

Thanks for the replies. I will restructure the experiments on my PC to have separate folder structures and then make sure they still run on the PC. Then I will delete all the experiments online and recreate them. Hopefully that cleans everything up.

I remember when I created the new project it was in a sub directory when uploaded and that was a problem but I will try it anyway.

I tried using separate directories and I get 403 Forbidden error when I try to run it. The same problem I had before when I used a sub directory

The directory structure I have is:


with the .psyexp file inside the experiment directory and then any subfolders for excel and phots files inside that.

when I try to create the new project on Pavlovia I get the following error when I select the path above.

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\gitlab\exceptions.py”, line 242, in wrapped_f
return f(*args, **kwargs)
File “C:\Program Files\PsychoPy3\lib\site-packages\gitlab\mixins.py”, line 204, in create
File “C:\Program Files\PsychoPy3\lib\site-packages\gitlab_init_.py”, line 589, in http_post
post_data=post_data, files=files, **kwargs)
File “C:\Program Files\PsychoPy3\lib\site-packages\gitlab_init_.py”, line 495, in http_request
gitlab.exceptions.GitlabHttpError: 400: {‘name’: [“can’t be blank”, “can contain only letters, digits, emojis, ‘’, ‘.’, dash, space. It must start with letter, digit, emoji or '’.”], ‘path’: [“can’t be blank”, “can contain only letters, digits, ‘_’, ‘-’ and ‘.’. Cannot start with ‘-’, end in ‘.git’ or end in ‘.atom’”, ‘is too short (minimum is 1 character)’], ‘limit_reached’: []}

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\pavlovia_ui\project.py”, line 146, in submitChanges
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\projects\pavlovia.py”, line 329, in createProject
raise e
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\projects\pavlovia.py”, line 324, in createProject
gitlabProj = self.gitlab.projects.create(projDict)
File “C:\Program Files\PsychoPy3\lib\site-packages\gitlab\exceptions.py”, line 244, in wrapped_f
raise error(e.error_message, e.response_code, e.response_body)
gitlab.exceptions.GitlabCreateError: 400: {‘name’: [“can’t be blank”, “can contain only letters, digits, emojis, ‘’, ‘.’, dash, space. It must start with letter, digit, emoji or '’.”], ‘path’: [“can’t be blank”, “can contain only letters, digits, ‘_’, ‘-’ and ‘.’. Cannot start with ‘-’, end in ‘.git’ or end in ‘.atom’”, ‘is too short (minimum is 1 character)’], ‘limit_reached’: []}

Ah ok, there are also hidden .git folders in your task folders. These are created when you make a new Pavlovia project. You should make sure these are deleted from your task folder before creating new separate Pavlovia tasks. If you still get the error, then there is something else happening, and the next thing to do is make sure you activated your project on Pavlovia. If that fails perhaps we can debug your html export.

It suggests something wrong with the naming or the project. It may also be related to running the project from your OneDrive folder, or that you have the experiments saved in a sub directory on your desktop. Im not sure but try moving them off your desktop first, and if that fails, out of your OneDrive.

this is what my directory structure looks like.

Until I saw the path I did not know that OneDrive was part of it. If you think it may be an issue I can try and move the psychopy folder directly onto C drive. As I said before the Bunny experiment was working fine online. Tt was only when I add the Toy experiment and tried to run it that I had a because it ran the bunny experiment instead.

sorry I forgot to mention when the bunny experiment worked online it was located directly in the psychopyfiles folder not in the BunnyExperiment folder.

Thanks for the pics. First, you should delete the .git folder from the PsychopyFiles directory, then open your task its own folder, and when you sync with Pavlovia it will ask you to create a new project, since the .git folder which links your folder to the online Pavlovia project no longer exists. If you collected data already, you want to make sure you have a back up before doing this.

Or, try just moving .git folder back into bunny exp folder.

I have deleted the .git folder.
I opened the experiment from the BunnyExperiment folder
I did the HTML export
I did the synch and created the new project
And it worked.
The Bunny Experiment runs online great!

Now I have to repeat the process for the Toy Experiment and see what happens. Hopefully I don’t have the original problem still. I’ll let you know.
Thanks for your help