psychopy.org | Reference | Downloads | Github

Auth error, PyschoPy git crash, and no projects appearing in pavlovia.org/explore


#1

I am trying to get a very simple task on Pavlovia (a visual duration test for validating timing on different web browsers).

I run into 2 possibly related problems, that have replicated accross browsers, new projects and accounts.

When I try and commit/push via the GUI the whole thing crashes, then that particular experiment will from that point onwards crash the GUI (this is v3.01b11 running on Windows 10).

It creates a project on gitlab, but no commit turns up. To remedy this I use git to push the commit via command line, and it appears fine – wonderful! All the HTML and resources are there in it’s proper folder etc.

However, when I try and find the project in the ‘explore’ section of pavlovia.org, I get an error message pop-up with some JSON, and I can see all the public ones from other people, but mine are not there:

[had to remove links because discourse wont let me post]

“{“origin”:”[ /pavlovia / server",“error”:“unable to list the experiments: TypeError: this.userIds is undefined :\n@:1:15\n”,“oauthToken”:“6efb0d119f4e75eead960521fc21a1f8cd150625e6c7379450a748c2abf5200e”,“context”:“when listing experiments available to the (authenticated) user”,“user”:{“two_factor_enabled”:false,“username”:“Alexander”,“theme_id”:1,“can_create_project”:true,“bio”:null,“confirmed_at”:“2018-11-12T14:29:58.099Z”,“twitter”:"",“shared_runners_minutes_limit”:null,“linkedin”:"",“color_scheme_id”:1,“last_sign_in_at”:“2018-11-12T14:29:58.205Z”,“web_url”:“gitlab pavlovia /Alexander”,“last_activity_on”:null,“external”:false,“skype”:"",“identities”:[],“id”:569,“name”:“alex”,“can_create_group”:true,“projects_limit”:100000,“current_sign_in_at”:“2018-11-12T14:29:58.205Z”,“created_at”:“2018-11-12T14:29:58.196Z”,“state”:“active”,“avatar_url”:“https: //secure .gravatar com /avatar/ef2f123c32343437e5a2e96f7df83ffa?s=80&d=identicon”,“location”:null,“organization”:null,“email”:“alexander.irvine@ mrc-cbu “,“website_url”:””}}"

Depending on the order of the ‘private’ /‘public’ buttons I press, the error is sometimes not seen, but the project still does not appear.

I have tried switching between Chrome and Firefox, re-installing the GUI, logging out and logging back in again, creating a new project, and also creating a brand-new user – and these errors all still persist!


#2

Just commenting in hope of resolving this.

Still can’t get my experiment up and running!