psychopy.org | Reference | Downloads | Github

All Pavlovia Experiments No Longer Working

URL of experiment: https://run.pavlovia.org/NikkiN/inter/
https://run.pavlovia.org/NikkiN/prac/

version: 2020.2.6
OS: macOS High Sierra
Browsers: Safari and Chrome

Description of the problem:
Hello,
I finished building my experiments 2 weeks ago and they worked fine when I ran them online. When I wanted to test them again this week, none of my experiments work anymore. The browser gives me the following error message:

And I get the following error message in the Runner:
Pushing to Pavlovia for the first time…Traceback (most recent call last):
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/app/pavlovia_ui/project.py”, line 517, in syncProject
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/psychopy/projects/pavlovia.py”, line 822, in firstPush
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/git/cmd.py”, line 548, in
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/git/cmd.py”, line 1014, in _call_process
File “/Applications/PsychoPy.app/Contents/Resources/lib/python3.6/git/cmd.py”, line 825, in execute
git.exc.GitCommandError: Cmd(’/Applications/PsychoPy.app/Contents/Resources/git-core/git’) failed due to: exit code(1)
cmdline: /Applications/PsychoPy.app/Contents/Resources/git-core/git push -u https://oauth2:f756f98e9995c1584ce2732fa40a82f9fd27edfa876177a9e4723c576c10aa44@gitlab.pavlovia.org/NikkiN/prac.git master
stderr: ‘To https://gitlab.pavlovia.org/NikkiN/prac.git
! [rejected] master -> master (fetch first)
error: failed to push some refs to ‘https://oauth2:f756f98e9995c1584ce2732fa40a82f9fd27edfa876177a9e4723c576c10aa44@gitlab.pavlovia.org/NikkiN/prac.git
hint: Updates were rejected because the remote contains work that you do
hint: not have locally. This is usually caused by another repository pushing
hint: to the same ref. You may want to first integrate the remote changes
hint: (e.g., ‘git pull …’) before pushing again.
hint: See the ‘Note about fast-forwards’ in ‘git push --help’ for details.’

Does anyone have any ideas what might be happening?

Thanks!

Hi @Karen, please what version of Safari and/or Chrome are you using? Thanks, x

Hi!
I’m using Safari Version 12.0.2 (13606.3.4.1.4) and Chrome Version 86.0.4240.193 (Official Build) (x86_64).

OK I don’t see any errors on Chrome, but yes made a note of patching PsychoJS to support Safari 12 in this respect, thanks for flagging, x

Hi @sotiri
Thanks for checking! :slight_smile: Is there anything you would suggest I check / read into? I don’t quite understand the error / what the problem might be.
Thank you!

Hi @Karen, no problem, code I wrote to allow for parsing array looking strings and which got recently pulled in to PsychoJS is using a JS String prototype method called matchAll that is unavailable in Safari 12, because I looked at the browser compatibility table and lazily decided Safari 13 support should be good enough. The issue has come up before. I now need to revisit that utility function and make tweaks to allow for the code to run on Safari 12 and other legacy browsers. I’m hoping to have a fix ready in the next few days, many thanks for your patience, x

Thank you so much for the explanation! I was going a little mad looking for solutions online. I’ll have a read through the other threads you recommended as well. Thanks again! :smiley: