Online experiment not working consistently on different computers

Description of the problem:
I have recently begun pilot testing my online experiment. Although, it works fine on most computers that have tested it a couple are getting the following error:


It has occurred exclusively on mac computers but a different mac user was also able to run the experiment fine. I have since converted the condition files from excel to csv files just in case this was the issue but it had no effect.

Just to add - everyone can start the experiment it is after the instructions that the error usually comes up

The error goes away when people use a different browser - perhaps related to the version of JavaScript

hi there: I am having the exact same issue, the subject was using Firefox, did yours also used Firefox?


No, I believe they were using safari on mac.
I think that if the subject uses a different browser or tries updating their version of Firefox the error should hopefully be gone!

thanks for your reply, so far I only had one subject reporting this issue to me, would you mind sharing if this has happened to many of your subjects or just one? Just want to determine if it’s going to be a serious issue. mine was using Firefox 66, so indeed quite old version.

I’m only in an early stage at the moment I’ve tested it on around 10 computers and the error came up twice (both times on mac computers). How many subjects have you tested?

I am also doing a small test right now for ~20 people. Waiting for others to get back to me, but so far only 1. I’ve run other tasks before (larger sample), but never had this issue.

EDIT:, seem to happen to only old browsers.

1 Like


I also had some problems with mac users and online experiment not working. I also don’t have a large test sample size but I will be soon pretesting a new expermient so I will let you know


Quick update: i tested my online experiment on different computers and on mac I had problem only with the Safari prowser. On the same machine the experiment worked just fine with mozilla

Hi @tandy, please check out the following thread for details, thanks, s.

I’ve just hit the error on Chrome on a iPhone – a combination which I’ve previously been able to use.

I’ve just double-checked an experiment which worked a few weeks ago. Looks like I need to upgrade from 2020.2.5 in case that helps.