404 Not Found Error in running experiment on pavlovia

URL of experiment: https://run.pavlovia.org/SpeechAcquisitionLab/skpam/index.html/
SpeechAcquisitionLab / skpam · GitLab

Description of the problem: I keep getting 404 Not Found error when I try to run the experiment on pavlovia, and I don’t know what’s the problem. It’d be appreciated if someone can take a look at it and suggest any solution. Thank you!


I downloaded your experiment, synced it with Pavlovia and was able to run it. I was using 2022.2.4, while you are using 2022.2.5. Anyway, I assume that the link you posted is wrong. I think it has to be https://run.pavlovia.org/SpeechAcquisitionLab/skpam instead of https://run.pavlovia.org/SpeechAcquisitionLab/skpam/index.html/. Using the shortened link, your experiment starts but because it is in pilot-mode, it won’t run.

Best wishes Jens

@JensBoelte thanks for your reply. when I click the link you suggest, I still get the same 404 error. I tried running the experiment after changing the status to Running instead of Pilot mode, but i still get the same error.


it is working for me. Did you refresh the browser cache?

I get

Best wishes Jens

Thank you so much for the quick reply. I had that problem before. What can I do to fix that problem? because when I change the status to Running, it didn’t work. I really wonder what the problem is here.


what problem do you mean now? The 404 error, the fact that the pilot token is no longer valid?

Best wishes Jens

the problem with the pilot token missing. I have gotten that error before.

@JensBoelte Thank you for your responses and suggestion. I think I found the solution here: Pavlovia
it was your first suggestion which was the solution all along. Thanks!