psychopy.org | Reference | Downloads | Github

You cannot compile JavaScript experiments (3.1.3)

Version: 3.1.3
OS: Windows
Description of the problem:

4.2070 ERROR You cannot compile JavaScript experiments with this version of PsychoPy. Please use version 3.0.0 or higher.

I just installed a new version of PsychoPy (3.1.3) and I can no longer compile JS experiments. Any idea why this is happening?

Jordan

@unagi_pie, regarding the response to the other post, are you unable to compile new experiments created afresh when the Experiment Settings Use version is left blank? It may be that you have version 1.90.2 selected as the version to use in Experiment Settings.

@dvbridges

Thanks for the help. As always, it was very quick and insightful. I appreciate it.

Interestingly, I found that in my experimental settings I had selected ‘latest’. However, when I looked through the options in the drop-down menu, I could only see versions up to 1.90.2. Now that I selected the blank option and gone back into experimental settings, I can see all versions of PsychoPy up to the current 3.1.3. I’m not sure how that could have happened, but I thought I would mention it.

1 Like