Viewport meta element (psychopy - js local browser loading image problem it seems)

URL of experiment: geritpfuhl/stroop2024db (

Description of the problem: code runs fine in psychopy, instrucs shown in JS local browser option, gets stuck when moving to routine that contains showing image.
Done: images are as *.png, loaded in additional resources, output path empty, tested with just one image to load (same error), used debug and get: a viewport meta element was not specified
suspect it is linked to smth with showing images, as the task version using word and colors only runs fine (basic Stroop vs emo Stroop version).


what is the exact error message? The link does not give access to your experiment. Is it public or was it a pilot-link? The latter expires within an hour.

Best wishes Jens

yes, it was a pilot link. The error message is 404, when then using ctrl+shift+i I get the viewport meta error in the browser. I set it now to public and here is the gitlab link Gerit Pfuhl / stroop2024db · GitLab ( and the files (3.7 MB)


there are two experiments in your experiment-folder. Which one do want to run, stroop_v2debug.psyexp or stroop_vdebug.exp?

Best wishes Jens

the stroop_v2debug just uses one picture but error message is the same, Want to run stroop_vdebug (loading more pictures). Thanks

Hello Gerit

Thanks for the clarification. I can reproduce the error. An error message appears for a period too short to read before it is replaced by an Error 404 message. Therefore it is difficult to come to bottom of this error.

BTW, there is no need to specify stimuli or condition-files in the Additional resources in the online tab when both are know at experiment start. There are a couple of old (?) routines in your experiment.

Best wishes Jens

ok, thanks, but how can I fix this error then? I used the builder as advised. Should I reproduce the task in the latest psychopy version? I used 2023.2.3

Hello Gerit

I am using the latest version of PsychoPy. You have set the PsychoPy version, which I have reset. It is usually not necessary to set the PsychoPy version unless you need features of a specific version, e.g. for eye-tracking experiments.

I have no idea how to fix this yet. PsychoPy is more flexible than PsychoJS in finding the images needed for the experiment. Therefore, the error only appears when you try to run the experiment online. PsychJS seems to expect an image that it cannot find, but I am not sure because I can not see the error message.

It could help to redo the experiment in a new folder. Copy the stimuli to a new folder and program the experiment anew.

Best wishes Jens

Hello Jens,

ok, will try that. Can you tell me how to not set the psychopy version? (I am not aware I did set it (it is not experiment - settings or in file - preferences). Thanks

Just leave Use PsychoPy version blank.

1 Like

When I tried to run it online it looked like there was some code trying to exit the experiment on the second instructions screen. Did I fail to press the correct key to consent or something?

@Jen When someone posts a link then you can check whether you can run it by editing the domain to
stroop_v2debug [PsychoPy]

1 Like

Hello Gerit

I rebuild this toy-experiment from scratch using the parameters of your experiment. It runs in a local web-browser. (3.6 MB)

You might want to delete the location column from your Excel-file as you don’t use it.

@wakecarter thanks for the tip.

1 Like

it was any key, I took out a lot of stuff to identify the bug a bit better (failed)

oh wow, awesome. I have a look at it. Would make my MA student so happy if it works finally. Thanks a ton