Videos and Pictures appear skewed

If this template helps then use it. If not then just delete and start from scratch.

OS Win11
PsychoPy version: 2022.2.4
Standard Standalone? (y/n) yes
What are you trying to achieve?:
Playing a Videos and presenting pictures.
What did you try to make it work?:
I checked the monitor options, they are correct.
Screen distance 57cm, Size 1920 x 1080 pix, Sceen width 30cm
I tried it with a new monitor setting
I tried it with another Windows computer
I tried it with different videos
I changed the players; with VLC it crashes , with movipy the video is super large and with ffpyplayer and opencv it appears skewed.
I installed a older version,
What specifically went wrong when you tried that?:

Videos and Pictures are alwas skewed, they are higher than they should be.

The code runs, with following warning messages:
2.1158 WARNING We strongly recommend you activate the PTB sound engine in PsychoPy prefs as the preferred audio engine. Its timing is vastly superior. Your prefs are currently set to use [‘sounddevice’, ‘PTB’, ‘pyo’, ‘pygame’] (in that order).
6.2285 WARNING User requested fullscreen with size [1024 768], but screen is actually [1920, 1080]. Using actual size
1.2228 WARNING Monitor specification not found. Creating a temporary one…
ioHub Server Process Completed With Code: 0
[ffpyplayer_abuffersink @ 00000299632f4e80] Removing channel layout 0x3, redundant with 2 channels
[ffpyplayer_abuffersink @ 0000029963967540] Removing channel layout 0x3, redundant with 2 channels

I don´t know where this fullscreen size 1024 768 comes from, as explained above in the settings it is correct. However this actually seems not to be the problem.

I am an absolute beginner to PsychoPy, I am very thankfull for any idea what I should change or check for. Thanks!


Try pressing Full-screen window in Monitor settings or writing down the actual size of your screen which seems to be 1920x1080.

I’ve tried both, already several times. Does not change anything.

What are your units?

What is the size of your image (in the component)?

If you set height units you need to set the size in the same ratio as the original.

I have tried all different units. I left the size [w,h] row empty. As I understood, with this row empty the video should play in its original size.

But now I discovered if I put the Units to pix and the tell it the actuall size of the video, it actually works! And same with hights, if I type in the actuall ratio it works.

Such an easy solution, sorry for bothering! :see_no_evil: Thanks :slight_smile:

1 Like