Monitor Centre Problem

OS (e.g. Win10): Win10
PsychoPy version (e.g. 1.84.x): 2021.1.2

What are you trying to achieve?:
I have created a fairly simple experiment where participants view video stimuli for 30s then make a judgement using the keyboard. I am planning to run the experiment online in fullscreen and I am using height units.

I am having a problem with the monitor centre where the builder seems to believe that my screen resolution is different than the one I calibrated. I have set my screen settings for the laptop I am creating the experiment on which is a standard 1920x1080 resolution (see screenshots) and called this ‘Monitor1’ and made sure that this monitor is selected in the experiment settings.

Despite this Psychopy seems to be treating the resolution as ‘1535x864’ instead - this shows as the window size under experiment settings which is greyed out when running the experiment in full-screen mode. There is no monitor listed in the monitor centre with this resolution.

I think this is causing some problems with setting the dimensions of my video stimuli in the builder (they look slightly distorted compared to when I play them directly from the file) and causing the cursor to be visible during stimulus presentation despite using a code component to hide it (and hiding it in the experiment settings).

What did you try to make it work?:
I have tried re-adding the correct monitor here and changing the window size manually but it reverts to 1534x864 as soon as I select the full screen option. I’ve read the documentation RE monitor centre too and I cannot see anything that I have done incorrectly.

Here is the message I get in the experiment runner when I run the experiment:

Running: C:\Users\charl\Dropbox\CHAR\ONLINE_DATA_COLLECTION_AUG2021\ML_EXP_1\ ##
82075.0104 INFO Loaded monitor calibration from [‘2021_09_13 19:15’, ‘2021_10_30 12:47’]
pygame 1.9.6
Hello from the pygame community. Contribute - pygame wiki
1.2665 WARNING We strongly recommend you activate the PTB sound engine in PsychoPy prefs as the preferred audio engine. Its timing is vastly superior. Your prefs are currently set to use [‘sounddevice’, ‘PTB’, ‘pyo’, ‘pygame’] (in that order).
14.1867 WARNING User requested fullscreen with size [1536 864], but screen is actually [1920, 1080]. Using actual size

Experiment ended.

This seems to show that it is not calling my ‘Monitor1’ calibration and that the incorrect screen resolution is being requested but I don’t know how to fix it.

Apologies if this is a simple error that I am making and thanks in advance!

1 Like