URL created by pavlovia missing /html end - need to manually extend

Description of the problem: When running the experiment, pavlovia creates the experiment URL for sharing / combining it with the recruitment system (e.g., Sona) under Recruitment → UrL. Yet, this link is sometimes missing the “/html” ending and then does not work → Error: “403 - Forbidden”. This can be easily fixed by extending this UrL manually at the end to include “/html”.

I’m not sure why the “/html” ending is sometimes missing, yet, in my experience this often (but not always!) happens when I directly jump from “inactive” to “running” (we have a lab account, so every researcher tests individually the experiments and then we upload the final version in our lab-account), in contrast to when jumping from “piloting” to “running”.
Is this also occuring somebody else? Since there is an easy fix, this is only an inconveniecne, but perhaps there is an easy future fix?
All the best

Hey SimonM,

I removed the people you tagged in your original post, but I might have a solution for you. In Experiment Settings → Online, leave “Output Path” empty. If you do this with an experiment you’ve already synchronized with Pavlovia, it can be that Pavlovia didn’t get the memo and still points to html. To fix that, delete your experiment from gitlab.pavlovia.org and delete the .git folder in your local folder, and sync again.

Best, Thomas

1 Like