No URL is generated for an active experiment in the Recruitment section of the Pavlovia Dashboard

URL of experiment:

Description of the problem:
I have uploaded and activated two experiments, but a URL is not generated for either experiment in the Recruitment section of the Pavlovia Dashboard. Below is what I see:

A previous post suggested just copying the URL that is generated when you run the experiment directly from Pavlovia. Is this the current and correct method for distributing the URL, or am I supposed to see a URL in the Recruitment area of the dashboard?

Thanks,
Ted

Hi @ted, have you set the status of the task to “RUNNING” or is the status inactive or in pilot mode?

Hey @dvbridges,

Yes, the status is running and we applied credits to each experiment.

Thanks, things look ok with your repo. @apitiot, would you mind taking a look?

Hello @ted,

I can confirm that your experiment is up and running.
I believe the connection to the server was briefly interrupted when you changed the status of your experiment to RUNNING and, as a consequence, the URL was not properly stored in the database. I’ve fixed that and it is now appearing on your experiment page.
All seems to be in order, but do let us know if you are experiencing any further issues.
Cheers,

Alain

Hi @apitiot,

Yes, the URLs are now present. Thanks for fixing this!

Ted

Hi @apitiot,

Correction, there is a URL for sequence 2 but not sequence 1. Could you also fix the URL issue for Sequence 1?

Thanks,
Ted

Oops. It is now.

Alain

This same problem has happened for me, is is blank after the url section

Hello @apitiot !

I have the same problem. I have created two different experiments. I set them as running and put 10 credits to each. however, while experiment A has the URL, experiment B does not have.

Am I getting this because I created the second version of the experiment by copying and giving it a new experiment name after I did some changes? However, when I run the experiment myself by clicking run button it seems like it works perfectly. So I am a bit confused. Would it work If I send the URL of the experiment that appears when I click run button although I cannot see the URL explicitly on DASHBOARD of my experiment?

These are the URL’s:

Many thanks!!
Emre

Hello @emregurbuz,

That must have been a temporary glitch in the matrix.
I’ve changed the mode of east_b down to INACTIVE and then back to RUNNING and it is working like a charm.
Cheers,

Alain

Hello @apitiot,

Woah, that was fast! Many thanks!

Cheers,
Emre

I also have the same problem - no URL generated, and in my case, hitting the run button takes me to a blank page (the code is not accessed). This is a repo that I am co-managing with one other person. Is there a way to check there isn’t also an error in the repo? https://pavlovia.org/leipsy/scheduler. Please let me know if you’d need other info. Thank you so much!

Also, I wasn’t sure where people would reply so I also replied to this post: No URL on Pavlovia