psychopy.org | Reference | Downloads | Github

Updates to resources and javascript not showing up

URL of experiment:

Description of the problem:
It has been over 24 hours since I last edited the javascript for my psychojs experiment hosted on Pavlovia but the code has not updated, as verified by looking at the Sources in the Chrome debugger. This project is over 7gb in size on Gitlab and I know that it takes a long time for changes in the resources to be reflected when running the experiment on Pavlovia. However, to my knowledge the delay in updating resources/javascript after changes in Gitlab has never taken this long. I have restarted the computer and refreshed the experiment page but still the version of the code I see on gitlab is not what pulls up in the debugger when I run the experiment from Pavlovia.

Just before updating my script I also updated a large CSV file in the resources (it contains over 12,000 lines). This change is also not reflected in Pavlovia. I am using the Web IDE in Gitlab to change my resources and javascript.

Do I just have to keep waiting? Could anyone explain why this update is taking so long to reflect in Pavlovia?

Why are you using WebIDE rather than syncing in Builder? Are you coding in jsPsych directly?

I’m coding directly in psychoJS.

I guess what initially drove me away from trying to learn builder was that I could not find a way to edit the resource array passed to psychoJS.start(). I’ve been coding for months in psychojs so it would be a nightmare to try to reverse engineer and put in the format of Builder.

It’s been about 36 hours now since I edited my resources/javascript and still no update to Pavlovia so I think my best bet is just going to be to duplicate my repository and create a new project.

Fair enough. I’ve added a jsPsych tag to the thread.