Unsuccessful sending triggers to Actiview through parallel port

If this template helps then use it. If not then just delete and start from scratch.

OS : Win7
PsychoPy version : PsychoPy3
Standard Standalone? (y/n) : yes
What are you trying to achieve? : send triggers to Actiview2 so I can connect PsychoPy with Biosemi system

What did you try to make it work? : I tried to use the parallel out component. I changed the address to the address I found on the Biosemi computer.

What specifically went wrong when you tried that?:
I was not able to see any triggers in ActiView.

Here are the two ports I found on the Biosemi computer. I wasn’t sure which one to use so I tried both, neither worked.

There was no error message and I’m pretty sure it’s not the issue with the parallel port, as I tried the port with Experiment Builder and it sends triggers fine.

Is there anything I was missing? Any help is appreciated!

COM1 and COM3 are more likely to be serial ports than parallel ports so setting those addresses is probably having no effect.

If someone in your lab has managed to set this up with Experiment Builder (as in the SR Research software?) then there must be settings in there that will tell you the port address and configuration for what you need. Could you check those settings?

1 Like

Hi Jon,

Thank you for your prompt response! I’ve tried a few things after seeing your answer.

  1. I checked the settings in Experiment Builder (yes the SR Research software). It’s not 100% clear how they connected Experiment Builder to Biosemi, but they used SET TTL actions and the device it connected to seemed to be a parallel port (at least the name suggested so). In the preference it said parallel port (add on card)

    I also didn’t find any serial port in the setting. Comparing the setting to a tutorial I found there should be a serial port name inserted but there was not.

  2. I’ve looked at the Biosemi computer again and found a list of all ports (not really sure if these are what they are, just including the list here in case it’s helpful)

  3. There are also these USB controllers. The Biosemi computer is connected to a USB receiver, if it helps…

  4. I tried removing the parallel port component and do it the serial way. I didn’t get any error message, but it didn’t show any triggers in Actiview either. But I could have done it wrong.

Thanks a lot!!

It looks like SREB is using PARALLELPORT_1 for the SetTTL action in your first picture. That means it is using a parallel port; if you look at the SREB experiment’s Devices->Parallel Port settings, what address is SREB using for the parallel port? You should be able to use the same parallel port address in PsychoPy.

Is the computer running PsychoPy the same as the Biosemi computer? If they are different computers, you want the address of the parallel port on the PsychoPy computer.

Thank you


Hi sol,

Thank you so much!! I finally got PsychoPy sending markers to the Biosemi computer. For some reason I thought it was the port on the Biosemi computer that I needed, and it worked when I changed the address to that on the PsychoPy computer. Thank you again for your help! I’ll mark this thread as solved.