'unexpected indent' error during sync when loading .csv file

URL of experiment: theodoros kapogianis / dm_nsgl · GitLab

Description of the problem:
I am importing a few .csv files which contain info regarding the paradigm during my sync with the online gitlab.
my first 3 .csv files import perfectly fine, but the 4th one gets the error below ‘unexpected indent’.
it is in the same format as the other .csv files. I have made sure the cursor is not on an empty cell when saving ( i have seen that as an issue in other posts).

when I attempt to extract the info from this file online my experiment crashes.

does anyone have any suggestions?

Hi @theokapo, when trying to read the csv in R in gives the warning “Incomplete final line”, which can be solved like this: 'Incomplete final line' warning when trying to read a .csv file into R - Stack Overflow

Maybe this also solves PsychoPys problem with the file.

Another thing I noticed was that the last cell (Graph …) is not in quotation marks. Maybe this is also a problem.

I tried the suggestions in the stackoverflow thread, no luck.

i’m not sure what is going on but I noticed that I can upload the file in one experiment, but not another.
described more in detail here:

in the derp2 experiment, if I import prac_toy_graphDataframe.csv I do not receive the unexpected indent error when syncing and I am able to extract the information.