| Reference | Downloads | Github

Unable to test the experiment offline

URL of experiment:

Description of the problem: I am trying to test experiment created using “export HTML” offline. When I open it in my browser (Firefox, also tested in Chrome), but the experiment is stuck on “initializing the experiment” screen. The link to github directory is above.
When I run experiment from the Builder, it works as intended.

Thank you very much!

You can’t just double-click an html and have it run like that. It needs to run off a server.

New in PsychoPy 2020.1 is the option to do that for you within PsychoPy with minimal hassle (in a local mode without uploading anywhere). In that new version, when you press run it brings up the Runner view as below, and this icon:image allows you (hopefully) to debug an online experiment locally.

Thank you. I tried the debug mode later yesterday, but I only get this message

55.6789     INFO     Investigating repo at C:/Users/agleo/Documents/Programming_projects/Web Version of fall2019_spring2020
55.7422     WARNING     We found a repository at C:/Users/agleo/Documents/Programming_projects/Web Version of fall2019_spring2020 but it doesn't point to You could create that as a remote to sync from PsychoPy.

and then nothing happened. I also uploaded it to Pavlovia, but when I try to run a pilot, I see this:

and nothing more. Is there a way on pavlovia to test why that happens?

Hi Jon, Hope you and your families are keeping well!

I run a similar problem to ‘Export HTML…’
I can run the File under PsychoPy 2020.1 on my pc (, but it can’t work when i was trying to export html and it give me error “ERROR Line 208: Unexpected token in ApproachAvoidance-legacy-browsers.js:disappointed_relieved:
Also I tried to test this icon (Run PsychoJS task in local debug mode) and it generated these files under ‘lib’ folder but didn’t give me more information.

Any help would be greatly appreciated!

I am not Jon, but I might help :slight_smile:

Here is the very good rundown of what unexpected tokens are. You probably have a typo somewhere where line 208 should be