Unable to download resource when piloting online

URL of experiment: https://run.pavlovia.org/TSKang/jointsimon-18-3

Description of the problem: the first part of my experiment requires looping through 15 images consecutively. These are labelled slide1.png from one through 15. The file extension is in lower case in both the file names and the stimulus control file. I read somewhere else then it might be that the file should be renamed with uppercase file extensions, I have already tried this, renaming the individual files and their labels in the control file. Still to no avail.
Unfortunately we encountered the following error:

  • when downloading the resources for experiment: jointsimon 18 3
  • unable to download resource: slide7.png (FILE_LOAD_ERROR)

Try to run the experiment again. If the error persists, contact the experiment designer.

Could you shared your repo? Then I’ll take a peek. I’m tpronk, I’ll need developer access.

Hello,

filenames should be written in the same case as in the stimulus-file. How do you load your stimuli-files? Via a reference from an Excel-file?

Best wishes Jens

Yep, I tried putting them all in uppercase, and lowercase, and various permutations in between. I tried removing the numbers, I tried only capitalise in the first letter, I tried everything I could think of! :slight_smile: And in each case, the spelling and capitalisation was the same in the control file and the images themselves.

Do I do that through Pavlovia itself, I can’t find the setting we need? Or do I have to go to git or something? Sorry, I’m definitely not a programmer!

No prob, here is a little guide. https://www.psychopy.org/online/sharingExperiments.html#adding-a-team-member

A friend has suggested that the reason the images might not be appearing is because they are not stored correctly in the resources folder, inside the HTML folder. I will try the hedge tomorrow, and let you know how I get on. If not, you get access to my repo! Thank you very much for your patience today, and the other day, Dr Pronk.

The weird thing is that inside my local directory there is no HTML folder. So I decided to delete my online project and sync to a new location. Even when I do that, it says that only two files are updated, not the many many files that I have in my folder. Bear in mind that now there are no files on the server, so everything should be updated.

Not a Dr yet, but hopefully I will be one day :). You haven’t shared your repo yet right? Here are some pointers that could help:

  • In Experiment Settings, Online tab, make “Output path” empty. (then it doesn’t export to an HTML folder; we recommend not exporting to HTML anymore in newer versions)
  • On your computer, in the folder that contains your experiment, delete the .git folder (you might need to enable showing hidden files for this). This ensures that you can sync afresh

Okay, I think everything has been synced fresh now. But when I try to pilot the study I get a 403 error: forbidden, and when I set it to running I get this error. I will work on giving you access to the repo now.

Error when updating the experiment: TSKang/joinsiomon-19-3-5

unable to pull project from GitLab repository: Remote ‘origin’ has no refspec set. You can set it as follows: ‘git config --add “remote.origin.fetch +refs/heads/:refs/heads/”’.

If the error persists, contact Pavlovia’s administrator.

Full description:

{
“origin”: “http://pavlovia.org/api/v2/experiments/TSKang/joinsiomon-19-3-5”,
“context”: “when updating the attribute(s) of an experiment”,
“pathWithNamespace”: “TSKang/joinsiomon-19-3-5”,
“user”: {
“id”: 11292,
“username”: “TSKang”,
“name”: “Tarandeep Kang”,
“email”: “tarandeep.kang@warwick.ac.uk
},
“experiment”: {
“gitlabId”: 94809,
“avatarUrl”: “”,
“creationDate”: “2021-03-19 09:44:50.503”,
“creatorId”: 11292,
“description”: “”,
“gitlabUrl”: “https://gitlab.pavlovia.org/TSKang/joinsiomon-19-3-5.git”,
“license”: {
“licenseId”: “d5d334bc-95de-11ea-a758-d05099d383f7”,
“approvals”: {
“Ethics”: false
},
“institutionName”: “University of Warwick”,
“expirationDate”: “2021-05-14”,
“managerId”: 6792,
“managerName”: “Linda Wilson”,
“managerEmail”: “pavloviawarwick@warwick.ac.uk”,
“institutionLogo”: “https://landportal.org/sites/landportal.org/files/styles/220heightmax/public/The-University-of-Warick-Logo.jpg
},
“name”: “joinsiomon 19 3 5”,
“nbForks”: 0,
“nbStars”: 0,
“pathWithNamespace”: “TSKang/joinsiomon-19-3-5”,
“pavloviaScore”: 0,
“pavloviaUrl”: “https://run.pavlovia.org/TSKang/joinsiomon-19-3-5”,
“platform”: “UNKNOWN”,
“recruitment”: {
“policy”: {
“type”: “URL”,
“url”: “https://run.pavlovia.org/TSKang/joinsiomon-19-3-5”,
“singleRun”: false
}
},
“runMode”: “LICENSE”,
“saveFormat”: “CSV”,
“saveIncompleteResults”: true,
“status”: “INACTIVE”,
“status2”: “RUNNING”,
“updateDate”: “2021-03-19 09:45:27”,
“userIds”: [
11292
],
“version”: “0”,
“visibility”: “private”
},
“error”: “unable to pull project from GitLab repository: Remote ‘origin’ has no refspec set.\nYou can set it as follows: ‘git config --add “remote.origin.fetch +refs/heads/:refs/heads/”’.”,
“errorCode”: null,
“httpStatusCode”: 500
}

I think I should’ve given you developer access now.

Your gitlab repo is completely empty. Let’s try something else. Could you ZIP your experiment folder, upload to a sharing site like wetransfer, and send me a link via a discourse private message? I’ll go check out your local repo.

Hey please could you share with us what operating system you are on and what version of PsychoPy you are running? This is syncing fine for me from 2020.2.10

Thanks!
Becca

Yes of course, I’m using 2021.1.2, and macOS Catalina.

OK, I tried a couple of things, and strangely enough, this seemed to work: after opening the experiment, in the Pavlovia menu, I picked my username to log in again, then synced. Also I could start the experiment on Pavlovia.

@TarandeepKang, I made you a maintainer of my repo (tp_simon3), so that you can clone it and download it from Pavlovia. With a bit of luck, that should fix everything!

Here are some instructions on how to download the experiment from within the builder. Searching for experiments on Pavlovia — PsychoPy v2021.1

1 Like

Strange indeed! But it works brilliantly on my end as well, both locally and on Pavlovia. One more question, and I promise this is the last one! How do I transfer this to my own, “name space” so I can link it with the Pavlovia account from my local institution, and with our ethical approval et cetera. I have tried to copy the files to a new folder, and then re-sync, but that didn’t help

Okay no worries! I am now the owner of the study, and my departmental ethics board is happy. Happy ethics board, happy PhD student! Thanks again for everything! Everything runs perfectly, from my own repo, locally and online!

Happy ethics, happy phd student, happy Thomas! At the gitlab page, try the fork button at the top right