psychopy.org | Reference | Downloads | Github

Unable to change the status from pilot to running

URL of experiment: https://run.pavlovia.org/bidirection/pebidirection/html/

Description of the problem:

Hi,

I am facing two issues:

1- My experiment worked well in pilot before without any error. I did not change any thing in the code or the experiment design. I am able to run the experiment in pilot now, but in the end I got this error.

Unfortunately we encountered the following error:

* when starting the experiment
* when opening a session for experiment: bidirection/pebidirection
* when opening a session on the server
* **the experiment status is PILOTING but the pilot token is missing from the URL**
`Try to run the experiment again. If the error persists, contact the experiment designer.`

2- I am not able to change the status from pilot to running, as the running bottom is not active.

I have many available credits, and I was able to run the experiment before.

I would be happy if you could help me to fix the issue.

Many thanks in advance.

Cheers,

I am currently having the same problem - suddenly the running status option is greyed out. I wonder if it is a site wide issue, as I’m having the same issue when I re-upload the experiment as a different project. Hopefully we will hear something soon!

I can confirm that is seems to be a wider issue, as this is the behavior I’m getting as well.

Looking into it :-/

Good evening @Marin_Dujmovic, @Alex_Boylan, and @Reza_Kakooee,

I am sorry for the mishap.
I added on Friday a few more checks to prevent accidentally setting an experiment that could not run into RUNNING mode but under some circumstances, the new tests made it impossible to address the situation, e.g. by assigning credits. The road to Hell is paved with good intentions…
It is fixed now. Many apologies for the trouble!
Cheers,

Alain

Hi.

Many participants of my project keep sending me an error message like this.

image

As they finished the experiment, they encountered this message…

The problem is I have to pay rewards upon their participation regardless of the result saved or not.

Is it related to this issue or their own internet connection?

I have no idea what’s going on because it used to be no problem.

And I am getting an error message when I try to login Pavlovia as well.

I hope this issue will get fixed soon.

Thanks!

Moon.

Hello @Moon,

We experienced a temporary loss of connection to the database server. We are back online.
I am very sorry for the mishap and hope it won’t have inconvenienced you too much.
Best wishes,

Alain

Hi @apitiot,
Thank you very much. Mine works now. But, there is another problem. After completing the experiment by participant (Running status), no data was saved in the database, although he received the following message
Untitled

There is not even any data folder in my repository.

Best,

The reason why your data directory is not filling up with participant results is that your experiment is setup such that results are written to the database. If you go to your experiment page, you should see that the saving format is: DATABASE. You can of course change it to: CSV.
In both cases, you can download your results using the Download Results button.

Alain

@apitiot:
Many thanks. Got it.
Seems you’ve changed the way you save data. Because, I can remember in the past you saved each participant data in a separate csv file, but now all are being saved in one csv file.
Best