psychopy.org | Reference | Downloads | Github

Troubles Installing Running Psychopy

Hello!

Trying to solve another issue, I uninstalled my most recent 32bit Psychopy (standalone version 2020.1.1.) today in order to install the 64-bit version.

But for some reason I cannot get it running.

I tried to install the 64-bit standalone version (and afterwards also the 32 one again), the installation succeeds, but when I start the application. Nothing happens. The cursor changes for a moment, but no window opens.

I followed the recommendations here, deleting the preference files, but it didn’t work
https://www.psychopy.org/troubleshooting.html#cleanprefs

when running form the command window, I get the following error:

C:\Users\admin>“C:\Program Files\PsychoPy3\python.exe” -m psychopy.app.psychop
pp
Traceback (most recent call last):
File “C:\Program Files\PsychoPy3\lib\runpy.py”, line 193, in _run_module_as_in"main", mod_spec)
File “C:\Program Files\PsychoPy3\lib\runpy.py”, line 85, in _run_code
exec(code, run_globals)
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\psychopyApp.”, line 104, in
main()
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\psychopyApp.”, line 100, in main
start_app()
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app\psychopyApp.”, line 22, in start_app
from psychopy.app._psychopyApp import PsychoPyApp
File “C:\Program Files\PsychoPy3\lib\site-packages\psychopy\app_psychopyAppy”, line 69, in
if hasattr(ctypes.windll.shcore, “SetProcessDpiAwareness”):
File “C:\Program Files\PsychoPy3\lib\ctypes_init_.py”, line 418, in __get
tr__
dll = self._dlltype(name)
*File “C:\Program Files\PsychoPy3\lib\ctypes_init_.py”, line 348, in _ini
self._handle = _dlopen(self._name, mode)
OSError: [WinError 126] Das angegebene Modul wurde nicht gefunden
(which translates into, the module was not found)

I also tried to install it through python, downloaded the most recent python version (3.8) and tried to install psychopy through the pip install command, but I get other error messages:
Downloading https://files.pythonhosted.org/packages/ed/27/6c49b70808f569b66ec7fac2e78f076e9b204db9cf5768740cff3d5a07ae/gevent-1.4.0.tar.gz (5.2MB)*
|████████████████████████████████| 5.2MB …
ERROR: Command errored out with exit status 1:
command: ‘C:\Users\admin\AppData\Local\Programs\Python\Python38\python.exe’
-c ‘import sys, setuptools, tokenize; sys.argv[0] = ‘"’"‘C:\Users\admin\AppData\Local\Temp\pip-install-8w_j5xzm\gevent\setup.py’"’"’; file=’"’"‘C:\Users\admin\AppData\Local\Temp\pip-install-8w_j5xzm\gevent\setup.py’"’"’
;f=getattr(tokenize, ‘"’"‘open’"’"’, open)(file);code=f.read().replace(’"’"’\r\n’"’"’, ‘"’"’\n’"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))*
’ egg_info --egg-base pip-egg-info
*cwd: C:\Users\admin\AppData\Local\Temp\pip-install-8w_j5xzm\gevent*

Complete output (113 lines):
Traceback (most recent call last):
File “C:\Users\admin\AppData\Local\Programs\Python\Python38\lib\site-packages\setuptools\msvc.py”, line 489, in _find_latest_available_vc_ver
return self.find_available_vc_vers()[-1]
IndexError: list index out of range
[and more]

Does anyone have an idea what is going wrong? In the afternoon Psychopy was still running, but now it is not…

Thanks for your help,
Katharina