Trouble uploading project to Pavlovia

Description of the problem: Hello all! I’m having trouble uploading an experiment to Pavlovia. There are no errors appearing because I’ll click on the green online syncing globe to sync it and nothing it will load but come to nothing… I’ve waited up to two hours and nothing happens so I’m feeling a bit stuck! Using 2021.2.3 on a Mac.

Hi @stephanie have you tried closing and reopening the app?

I have, but it comes up with the same problem.

Does the sync dialog appear but then just do nothing, or does it not appear? Is there any output in the Runner window?

You can also sync via the :pavlovia_info: Project Info dialog - have you tried from there?



Tried and got the same response of it loading but nothing happening. In the runner it does say I am using a different version of the exp but it runs normally in the runner

Does it matter that my conditions files are in XLSX??

uploaded CVS files instead and same response so nevermind

ok fixed the problem with the second image so ignore that


these are the two most recent from my runner, thanks!

This is strange, are you able to update to the latest version? It may be something we’ve fixed since then, or at least will deliver an error which will now be caught and displayed so there’s something to work with.

Ok so I tried it on a newer version and it says that “No module named ‘psychopy.tests’ exists”. I read another post and it said that is due to making it in an older version. So It uploaded to Pavlovia before in this old version, but then I had to change the units to height and now it will not upload.